aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-params-validate/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-10-19 02:02:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-10-19 07:28:47 +0000
commit162ef0625cb7c816c362f85b2e357a48a64b6921 (patch)
tree24ce00c084df5977dafede34bae4851206493e14 /main/perl-params-validate/APKBUILD
parent5ad06e0a539d0326b218e7d1bb74a6d2c725c998 (diff)
main/perl-params-validate: upgrade to 1.30
Diffstat (limited to 'main/perl-params-validate/APKBUILD')
-rw-r--r--main/perl-params-validate/APKBUILD33
1 files changed, 12 insertions, 21 deletions
diff --git a/main/perl-params-validate/APKBUILD b/main/perl-params-validate/APKBUILD
index 48c6b9842fb..20699e4ba28 100644
--- a/main/perl-params-validate/APKBUILD
+++ b/main/perl-params-validate/APKBUILD
@@ -1,43 +1,34 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-params-validate
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Params-Validate
-pkgver=1.29
-pkgrel=4
+pkgver=1.30
+pkgrel=0
pkgdesc="Validate method/function parameters"
url="https://metacpan.org/release/Params-Validate/"
arch="all"
license="Artistic-2.0"
-cpandepends="perl-module-implementation"
-cpanmakedepends="perl-test-fatal perl-module-implementation perl-test-requires"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends perl-module-build"
+depends="perl perl-module-implementation"
+makedepends="perl-dev perl-module-build"
+checkdepends="perl-test-requires perl-test-fatal"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/Params-Validate-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- perl Build.PL installdirs=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
./Build
}
check() {
- cd "$builddir"
./Build test
}
package() {
- cd "$builddir"
- ./Build install destdir="$pkgdir"
+ ./Build install --destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="afa887d1ce60d38b82cbf3ad88fb892f473e0fa45db528b68e66bbb800058af453180cc96afddae56a2cdad8ec531a587e7aac36b6869c489caa6dd36a57a385 Params-Validate-1.29.tar.gz"
+sha512sums="ca6b54a55dc003be6933ad5a9353abf96f2decfc681354fabc974e9666b89b3afe8394cd0a13ec91a5f84c825cbc0b4697a4977bf773feabfefab57006c9f20e Params-Validate-1.30.tar.gz"