aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-test-fatal
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-06-27 10:34:09 -0400
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-06-27 10:34:41 -0400
commit50997f223050991c290ac52fc1300cbaaf797fca (patch)
tree45d8d748c2903964e498f22cc41e2c71c57c2707 /main/perl-test-fatal
parentf97cb36839b3e6371398ba05e82b7316cf08dc3b (diff)
main/perl-test-fatal: upgrade to 0.006
Diffstat (limited to 'main/perl-test-fatal')
-rw-r--r--main/perl-test-fatal/APKBUILD36
1 files changed, 17 insertions, 19 deletions
diff --git a/main/perl-test-fatal/APKBUILD b/main/perl-test-fatal/APKBUILD
index aecb8a40ab0..8b86b494248 100644
--- a/main/perl-test-fatal/APKBUILD
+++ b/main/perl-test-fatal/APKBUILD
@@ -1,33 +1,31 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=perl-test-fatal
-pkgver=0.005
+_pkgreal=Test-Fatal
+pkgver=0.006
pkgrel=0
-pkgdesc="Test::Fatal perl module"
+pkgdesc="incredibly simple helpers for testing code with exceptions"
url="http://search.cpan.org/dist/Test-Fatal/"
arch="noarch"
-license="GPLv2 or Artistic"
-depends="perl perl-try-tiny"
-makedepends="perl-dev"
-install=""
+license="GPL PerlArtistic"
+cpandepends="perl-try-tiny"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Fatal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir"/Test-Fatal-$pkgver
prepare() {
- local i
cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ make && make test
}
package() {
@@ -36,4 +34,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="8fd91391e82ea4290eb0cf8409393485 Test-Fatal-0.005.tar.gz"
+md5sums="a984aa4d4088892c0454cbfce35e54d9 Test-Fatal-0.006.tar.gz"