aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-time-hires/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-02-19 15:20:30 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-19 15:24:32 +0000
commit5bcfa2d251b77938976733778b0e4d364c767279 (patch)
tree0d54b524b5521cdc5e47f2508c407cd2ce7071e6 /main/perl-time-hires/APKBUILD
parent31cdc13dfc1b3d4010c32af05193d228b62165ca (diff)
main/perl-time-hires: upgrade to 1.9760
Modernize APKBUILD, update license, explicitly disable tests
Diffstat (limited to 'main/perl-time-hires/APKBUILD')
-rw-r--r--main/perl-time-hires/APKBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/main/perl-time-hires/APKBUILD b/main/perl-time-hires/APKBUILD
index bba9a8a6ee6..b510bfcfd2f 100644
--- a/main/perl-time-hires/APKBUILD
+++ b/main/perl-time-hires/APKBUILD
@@ -2,46 +2,42 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-time-hires
-_pkgreal=Time-HiRes
-pkgver=1.9758
+_pkgname=Time-HiRes
+pkgver=1.9760
pkgrel=0
pkgdesc="High resolution alarm, sleep, gettimeofday, interval timers"
url="http://search.cpan.org/~jhi/Time-HiRes/"
arch="all"
-license="GPL PerlArtistic"
+license="GPL-1.0-only Artistic-1.0-Perl"
cpandepends=""
cpanmakedepends=" "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/J/JH/JHI/$_pkgreal-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgreal-$pkgver"
+options="!check" # see comment below
+source="https://cpan.metacpan.org/authors/id/A/AT/ATOOMIC/Time-HiRes-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
- default_prepare || return 1
-
- cd "$builddir"
+ default_prepare
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
check() {
- cd "$builddir"
# tests depends on hi res support of timestamps in filesystem
# we cannot guarantee that we have that so skip tests for now
-# make test
+ # make test
return 0
}
@@ -50,4 +46,4 @@ doc() {
replaces="perl-doc"
}
-sha512sums="1328025c816cff8b53bd310771ffd2bc63f8ef0204cf2d871ad600f10a8afc975f824e39e4d954b48f211ce08564f002524fbaf03450c4ed9d88a4d154c80369 Time-HiRes-1.9758.tar.gz"
+sha512sums="f355566740cb5d4dd533da2cb9209d955e5b7f6ed9e67c7fa37ca8336bacffe32d037700104915580c5a00534b5f2ff502542c4c4114e5f67e51e46856128b2a Time-HiRes-1.9760.tar.gz"