aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-uri/APKBUILD
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-04-27 14:20:06 +0000
committerTimo Teräs <timo.teras@iki.fi>2019-05-28 09:56:38 +0300
commitb46de91cc77c1e550ba980cd4abd5c300818179e (patch)
tree5c4eb725fdf861ce5e56cf43b1f601cd28b7c30b /main/perl-uri/APKBUILD
parentdaf61f5828751977dc5c01319202d11ad7d2fd70 (diff)
main/perl-uri: upgrade to 1.76
Diffstat (limited to 'main/perl-uri/APKBUILD')
-rw-r--r--main/perl-uri/APKBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/main/perl-uri/APKBUILD b/main/perl-uri/APKBUILD
index b935db53cda..5d367ee007f 100644
--- a/main/perl-uri/APKBUILD
+++ b/main/perl-uri/APKBUILD
@@ -1,36 +1,35 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-uri
-pkgver=1.74
+_pkgreal=URI
+pkgver=1.76
pkgrel=0
-pkgdesc="Perl Module: form Resource Identifiers (absolute and relative)"
-url="http://search.cpan.org/dist/URI/"
+pkgdesc="Uniform Resource Identifiers (absolute and relative)"
+url="https://metacpan.org/release/URI/"
arch="noarch"
-license="PerlArtistic"
-subpackages="$pkgname-doc"
+license="GPL-1.0-or-later Artistic-1.0-Perl"
depends="perl"
+cpancheckdepends="perl-test-needs"
makedepends="perl-dev"
-checkdepends="perl-test-needs"
+checkdepends="$cpancheckdepends"
replaces="perl-uri-escape"
-source="http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/URI-$pkgver.tar.gz"
-
-builddir="$srcdir"/URI-$pkgver
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/O/OA/OALDERS/URI-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
- perl Makefile.PL INSTALLDIRS=vendor
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name perllocal.pod -delete
- find "$pkgdir" -name .packlist -delete
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="b537bd09c355989a2bb1919e2c228cf189e57f993add4246fa482d8ee5ec814266c6fb3229befce2f294456ee784a819d9a54013c43a2ad41b5d8914fabf046b URI-1.74.tar.gz"
+sha512sums="1fcb02692bdf5f223c2878569615d153b3c4c5adc04c33aee23f3f015e08b4895b03536ef3a8c7cb7a334c2faa056e5e46c805d56d810704cba63d96136e0a83 URI-1.76.tar.gz"