aboutsummaryrefslogtreecommitdiffstats
path: root/main/php/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-05-15 06:22:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-15 06:22:51 +0000
commit36e33d6dc1164a8c990d7a4ed8b2f37cf752d382 (patch)
treeecbaf2e3fa8c600997912ecde482ed581f9a3499 /main/php/APKBUILD
parentc31b996403d1d609be5e2f081b3b2c5d669852ef (diff)
main/php: fix dependency issue for wddx
ref #1848
Diffstat (limited to 'main/php/APKBUILD')
-rw-r--r--main/php/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index e7b1e2936bd..88a376697ed 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=php
pkgver=5.4.14
-pkgrel=2
+pkgrel=3
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
arch="all"
@@ -395,6 +395,7 @@ pear() {
_mv_ext() {
local ext=$1
+ local ini=$ext.ini
pkgdesc="${ext} extension for PHP"
# extension dependencies
@@ -403,10 +404,16 @@ _mv_ext() {
fi
depends="${pkgname} ${depends}"
+ # work around dependency issue
+ # https://bugs.alpinelinux.org/issues/1848
+ if [ "$ext" = "wddx" ]; then
+ ini=xml_$ext.ini
+ fi
+
mkdir -p "$subpkgdir"/$_extdir
mv "$pkgdir"/$_extdir/${ext}.so "$subpkgdir"/$_extdir/ || return 1
mkdir -p "$subpkgdir"/etc/php/conf.d
- echo "extension=${ext}.so" > "$subpkgdir"/etc/php/conf.d/${ext}.ini
+ echo "extension=${ext}.so" > "$subpkgdir"/etc/php/conf.d/$ini
}
bcmath() { _mv_ext bcmath; }