aboutsummaryrefslogtreecommitdiffstats
path: root/main/php/APKBUILD
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-04-07 04:36:05 -0500
committerMatt Smith <mcs@darkregion.net>2011-04-07 04:36:05 -0500
commit6bcb03d73fe632a69103fcf5a5ecf19e856fdd40 (patch)
tree44a02f53291ee4e878653815a8d21ff2e10e179b /main/php/APKBUILD
parenta78c5e790c0379a90ab5d0f60fa90792f01adbdd (diff)
main/php: fixed remaining dependency issues, added php-ctype, php-enchant, php-xmlreader, gdbm support to php-dba
Changelog (php-5.3.6-r2 -> r3) - removed cyrus-sasl-dev from makedepends; php-ldap *could* use it, but there are issues with it finding sasl.h (let me know if you fix it) - added gdbm support to php-dba - added php-ctype, php-enchant, and php-xmlreader - removed --disable-all from ./configure line (it's best to keep defaults enabled) - php extensions now depend on the php package - fixed remaining inter-extension dependency issues
Diffstat (limited to 'main/php/APKBUILD')
-rw-r--r--main/php/APKBUILD109
1 files changed, 61 insertions, 48 deletions
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index 36f12871488..d96e6da835e 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php
pkgver=5.3.6
_suhosinver=5.3.6-0.9.10
-pkgrel=2
+pkgrel=3
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
arch="all"
@@ -14,18 +14,20 @@ makedepends="pcre-dev libxml2-dev libiconv-dev openssl-dev zlib-dev bzip2-dev
curl-dev libpng-dev jpeg-dev freetype-dev libmcrypt-dev mysql-dev
sqlite-dev libtool libltdl postgresql-dev db-dev unixodbc-dev icu-dev
gd-dev gmp-dev gettext-dev imap-dev aspell-dev
- net-snmp-dev libxslt-dev cyrus-sasl-dev openldap-dev pkgconfig
+ net-snmp-dev libxslt-dev openldap-dev pkgconfig
libgcrypt-dev apache2-dev apr-dev apr-util-dev libevent-dev
- readline-dev"
+ readline-dev enchant-dev gdbm-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-common $pkgname-cgi
$pkgname-cli $pkgname-fpm $pkgname-apache2 $pkgname-embed
$pkgname-pear
$pkgname-bcmath
$pkgname-bz2
$pkgname-calendar
+ $pkgname-ctype
$pkgname-curl
$pkgname-dba
$pkgname-dom
+ $pkgname-enchant
$pkgname-exif
$pkgname-ftp
$pkgname-gd
@@ -60,6 +62,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-common $pkgname-cgi
$pkgname-sysvsem
$pkgname-sysvshm
$pkgname-xml
+ $pkgname-xmlreader
$pkgname-xmlrpc
$pkgname-xsl
$pkgname-zip
@@ -71,7 +74,7 @@ source="http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2
php-install-pear-xml.patch
php-uclibc.patch
suhosin-patch-${_suhosinver}.patch
- php-fpm.init
+ php-fpm.initd
php5-module.conf
"
@@ -121,68 +124,76 @@ build() {
--enable-shared \
--mandir=/usr/share/man \
--with-pic \
- --disable-all
"
- _phpextensions="--enable-bcmath=shared \
+ _phpextensions=" \
+ --enable-bcmath=shared \
+ --with-bz2=shared \
--enable-calendar=shared \
+ --with-cdb \
+ --enable-ctype=shared \
+ --with-curl=shared \
+ --with-curlwrappers \
--enable-dba=shared \
+ --with-db4=shared \
--enable-dom=shared \
+ --with-enchant=shared \
--enable-exif=shared \
+ --with-flatfile=shared \
+ --with-freetype-dir=shared,/usr \
--enable-ftp=shared \
+ --with-gd=shared,/usr \
--enable-gd-native-ttf \
+ --with-gdbm=shared \
+ --with-gettext=shared \
+ --with-gmp=shared \
+ --with-iconv=shared \
+ --with-icu-dir=/usr \
+ --with-imap=shared \
+ --with-imap-ssl=shared \
+ --with-inifile=shared \
--enable-intl=shared \
+ --with-jpeg-dir=shared,/usr \
--enable-json=shared \
+ --with-ldap=shared \
--enable-libxml=shared \
--enable-mbregex \
- --enable-mbstring \
+ --enable-mbstring=all \
+ --with-mcrypt=shared \
+ --with-mysql=shared,mysqlnd \
+ --with-mysql-sock=/var/run/mysqld/mysqld.sock \
+ --with-mysqli=shared,mysqlnd \
+ --with-openssl=shared \
+ --with-pcre-regex=/usr \
--enable-pdo=shared \
+ --with-pdo-mysql=shared,mysqlnd \
+ --with-pdo-odbc=shared,unixODBC,/usr \
+ --with-pdo-pgsql=shared \
+ --with-pdo-sqlite=shared,/usr \
+ --with-pgsql=shared \
--enable-phar=shared \
+ --with-png-dir=shared,/usr \
--enable-posix=shared \
+ --with-pspell=shared \
+ --with-regex=php \
--enable-session \
--enable-shmop=shared \
+ --with-snmp=shared \
--enable-soap=shared \
--enable-sockets=shared \
+ --with-sqlite=shared \
--enable-sqlite-utf8 \
+ --with-sqlite3=shared,/usr \
--enable-sysvmsg=shared \
--enable-sysvsem=shared \
--enable-sysvshm=shared \
+ --with-unixODBC=shared,/usr \
--enable-xml=shared \
+ --enable-xmlreader=shared \
+ --with-xmlrpc=shared \
+ --with-xsl=shared \
--enable-zip=shared \
- --with-bz2=shared \
- --with-curl=shared \
- --with-db4=shared \
- --with-freetype-dir=shared,/usr \
- --with-gd=shared,/usr \
- --with-gettext=shared \
- --with-gmp=shared \
- --with-iconv=shared \
- --with-icu-dir=/usr \
- --with-imap-ssl=shared \
- --with-imap=shared \
- --with-jpeg-dir=shared,/usr \
- --with-ldap=shared \
- --with-mcrypt=shared \
- --with-openssl=shared \
- --with-pcre-regex=/usr \
- --with-mysql-sock=/var/run/mysqld/mysqld.sock \
- --with-mysql=shared,mysqlnd \
- --with-mysqli=shared,mysqlnd \
- --with-pdo-mysql=shared,mysqlnd \
- --with-unixODBC=shared,/usr \
- --with-pdo-odbc=shared,unixODBC,/usr \
- --with-pgsql=shared \
- --with-pdo-pgsql=shared \
- --with-sqlite3=shared,/usr \
- --with-sqlite=shared \
- --with-pdo-sqlite=shared,/usr \
- --with-png-dir=shared,/usr \
- --with-pspell=shared \
- --with-regex=php \
- --with-snmp=shared \
- --with-xmlrpc=shared \
- --with-xsl=shared \
- --with-zlib=shared \
+ --with-zlib=shared \
--without-db1 \
--without-db2 \
--without-db3 \
@@ -242,7 +253,7 @@ package() {
"$pkgdir"/usr/bin/php-fpm || return 1
install -D -m644 "$srcdir"/build-fpm/sapi/fpm/php-fpm.conf \
"$pkgdir"/etc/php/php-fpm.conf || return 1
- install -D -m755 "$srcdir"/php-fpm.init "$pkgdir"/etc/init.d/php-fpm
+ install -D -m755 "$srcdir"/php-fpm.initd "$pkgdir"/etc/init.d/php-fpm
# enable some default options
sed -ri -e "s~^;(error_log)(.*)~\1 = /var/log/php-fpm.log~" \
-e "s/^;(pm.start_servers)/\1/" \
@@ -345,7 +356,8 @@ _mv_ext() {
# extension dependencies
if [ -n "${2-}" ]; then
depends="${2-}"
- fi
+ fi
+ depends="${pkgname} ${depends}"
mkdir -p "$subpkgdir"/$_extdir
mv "$pkgdir"/$_extdir/${ext}.so "$subpkgdir"/$_extdir/ || return 1
@@ -356,10 +368,11 @@ _mv_ext() {
bcmath() { _mv_ext bcmath; }
bz2() { _mv_ext bz2; }
calendar() { _mv_ext calendar; }
+ctype() { _mv_ext ctype; }
curl() { _mv_ext curl; }
dba() { _mv_ext dba; }
dom() { _mv_ext dom; }
-#enchant() { _mv_ext enchant; }
+enchant() { _mv_ext enchant; }
exif() { _mv_ext exif; }
ftp() { _mv_ext ftp; }
gd() { _mv_ext gd; }
@@ -380,15 +393,14 @@ pdo_mysql() { _mv_ext pdo_mysql php-pdo; }
pdo_odbc() { _mv_ext pdo_odbc php-pdo; }
pdo_pgsql() { _mv_ext pdo_pgsql php-pdo; }
pdo_sqlite() { _mv_ext pdo_sqlite php-pdo; }
+pgsql() { _mv_ext pgsql; }
phar() {
_mv_ext phar
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/phar* "$subpkgdir"/usr/bin/
}
posix() { _mv_ext posix; }
-pgsql() { _mv_ext pgsql; }
pspell() { _mv_ext pspell; }
-#session() { _mv_ext session; }
shmop() { _mv_ext shmop; }
snmp() { _mv_ext snmp; }
soap() { _mv_ext soap; }
@@ -399,7 +411,8 @@ sysvmsg() { _mv_ext sysvmsg; }
sysvsem() { _mv_ext sysvsem; }
sysvshm() { _mv_ext sysvshm; }
xml() { _mv_ext xml; }
-xmlrpc() { _mv_ext xmlrpc; }
+xmlreader() { _mv_ext xmlreader php-dom; }
+xmlrpc() { _mv_ext xmlrpc php-xml; }
xsl() { _mv_ext xsl php-dom; }
zip() { _mv_ext zip; }
zlib() { _mv_ext zlib; }
@@ -408,5 +421,5 @@ md5sums="2286f5a82a6e8397955a0025c1c2ad98 php-5.3.6.tar.bz2
5111e3be06d391f8772587c675240fab php-install-pear-xml.patch
31458da0ca6cb4ca2cbdaa2d32ab386d php-uclibc.patch
54d3a7830c103f0efe94ed44c40dfad5 suhosin-patch-5.3.6-0.9.10.patch
-8f2bb2b744a2de50025842cb51fb6a3a php-fpm.init
+8f2bb2b744a2de50025842cb51fb6a3a php-fpm.initd
67719f428f44ec004da18705cbabe2ee php5-module.conf"