aboutsummaryrefslogtreecommitdiffstats
path: root/main/pjproject/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-09-25 15:26:25 +0300
committerTimo Teräs <timo.teras@iki.fi>2018-09-25 15:27:55 +0300
commit81218149c70d831fececeefc5a14e5c1fa9f6929 (patch)
tree24551c41d2752aca4871498e443df635af99f180 /main/pjproject/APKBUILD
parentd99aa8e3f0c88299d5094270594708793d135723 (diff)
main/pjproject: build release build
Adding -DNDEBUG will disable assertations. Provides better performance. This also sort of hides an issue asterisk is having: https://issues.asterisk.org/jira/browse/ASTERISK-26664
Diffstat (limited to 'main/pjproject/APKBUILD')
-rw-r--r--main/pjproject/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/pjproject/APKBUILD b/main/pjproject/APKBUILD
index da2ee3d075c..860f61089a6 100644
--- a/main/pjproject/APKBUILD
+++ b/main/pjproject/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pjproject
pkgver=2.7.2
-pkgrel=2
+pkgrel=3
pkgdesc="CLI Softphone"
url="http://www.pjsip.org/pjsua.htm"
arch="all"
@@ -46,6 +46,7 @@ prepare() {
build() {
cd "$builddir"
+ export CFLAGS="-DNDEBUG $CFLAGS"
./configure \
--build=$CBUILD \
--host=$CHOST \