aboutsummaryrefslogtreecommitdiffstats
path: root/main/postfix/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-06-12 11:29:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-12 11:29:51 +0000
commit37c150666498a4b027ff4f20c8695ab8211e5010 (patch)
treebc7ad99e91d9184133bb9d415cfaabe7a23793d8 /main/postfix/APKBUILD
parent370a4776ca67151a276ecdbb4ebd50075b8fe68b (diff)
main/postfix: add support for lmdb
fixes #8937
Diffstat (limited to 'main/postfix/APKBUILD')
-rw-r--r--main/postfix/APKBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/main/postfix/APKBUILD b/main/postfix/APKBUILD
index 18fc0b59a55..dbb1a1d9b1e 100644
--- a/main/postfix/APKBUILD
+++ b/main/postfix/APKBUILD
@@ -3,17 +3,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postfix
pkgver=3.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
url="http://www.postfix.org/"
arch="all"
license="IPL-1.0"
depends=
makedepends="db-dev pcre-dev libressl-dev postgresql-dev mariadb-connector-c-dev openldap-dev
- cyrus-sasl-dev perl file sqlite-dev linux-headers coreutils"
+ cyrus-sasl-dev perl file sqlite-dev linux-headers coreutils
+ lmdb-dev"
install="$pkgname.pre-install"
-subpackages="$pkgname-doc $pkgname-ldap $pkgname-mysql $pkgname-pcre
- $pkgname-pgsql $pkgname-sqlite $pkgname-stone"
+subpackages="$pkgname-doc
+ $pkgname-ldap:_mv_dict
+ $pkgname-lmdb:_mv_dict
+ $pkgname-mysql:_mv_dict
+ $pkgname-pcre:_mv_dict
+ $pkgname-pgsql:_mv_dict
+ $pkgname-sqlite:_mv_dict
+ $pkgname-stone"
+
options="!check suid" # No test suite.
pkgusers="postfix"
pkggroups="postfix postdrop"
@@ -71,9 +79,11 @@ build() {
# sqlite
ccargs="$ccargs -DHAS_SQLITE $(pkg-config --cflags sqlite3)"
+ # lmdb
+ ccargs="$ccargs -DHAS_LMDB $(pkg-config --cflags lmdb)"
+
#
# AUXLIBS_CDB="$cdb_libs" \
- # AUXLIBS_LMDB="$lmdb_libs" \
# compile
make DEBUG="" \
@@ -85,6 +95,7 @@ build() {
AUXLIBS_PCRE="$(pkg-config --libs libpcre)" \
AUXLIBS_PGSQL="$(pkg-config --libs libpq)" \
AUXLIBS_SQLITE="$(pkg-config --libs sqlite3)" \
+ AUXLIBS_LMDB="$(pkg-config --libs lmdb)" \
dynamicmaps=yes \
shared=yes \
makefiles
@@ -130,7 +141,7 @@ package() {
"$pkgdir"/var/spool/postfix/public
cd "$pkgdir"/etc/postfix/
- for map in ldap mysql pcre pgsql sqlite; do
+ for map in ldap mysql pcre pgsql sqlite lmdb; do
msg "split $map"
_mvline "^\s*$map" "$map" dynamicmaps.cf
done
@@ -138,8 +149,7 @@ package() {
}
_mv_dict() {
- local m=$1
- shift
+ local m=${subpkgname##*-}
pkgdesc="$m map support for postfix"
depends=
mkdir -p "$subpkgdir"/usr/lib/postfix \
@@ -150,12 +160,6 @@ _mv_dict() {
"$subpkgdir"/etc/postfix/dynamicmaps.cf.d/
}
-ldap() { _mv_dict ldap ; }
-mysql() { _mv_dict mysql ;}
-pcre() { _mv_dict pcre ; }
-pgsql() { _mv_dict pgsql ; }
-sqlite() { _mv_dict sqlite ; }
-
stone() {
cd $builddir
pkgdesc="Postfix simulation and testing tools"