aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-munkres/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2019-02-16 15:38:46 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-02-20 08:55:13 +0000
commit6572851d65a0115f3f04f4ca47dd27cc12898baf (patch)
tree37dcf48b8d8f459b0d06007e351968d2fca7f638 /main/py-munkres/APKBUILD
parent0dc224ca999a1e852f82a02648b424be64436978 (diff)
main/py-munkres: only Python 3 is supported now
Diffstat (limited to 'main/py-munkres/APKBUILD')
-rw-r--r--main/py-munkres/APKBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/main/py-munkres/APKBUILD b/main/py-munkres/APKBUILD
deleted file mode 100644
index f7197190aa1..00000000000
--- a/main/py-munkres/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-munkres
-_pkgname=munkres
-pkgver=1.0.12
-pkgrel=0
-pkgdesc="Munkres algorithm for the assignment problem"
-url="http://bmc.github.com/munkres/"
-arch="noarch"
-license="BSD"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://github.com/bmc/munkres/archive/release-$pkgver.tar.gz#/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-release-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="9049fd350b739c9095b6e1da8fe0041210d4723ab8c0c6a7fc9943392bebf9eb224c6f420c8158a47607277e13fba2f3c7803ee222d58e8e3720d5647f44e596 munkres-1.0.12.tar.gz"