aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-phonenumbers/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-08 08:37:36 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-11-08 23:14:15 +0100
commit644acaf577ece2e6562e08f38f16b162da46cb80 (patch)
tree5632e016dde2c884721d4c300bb26bee3d83542d /main/py-phonenumbers/APKBUILD
parentda589be8409e9735f379f2e8f6702a9094f64f2a (diff)
main/py-phonenumbers: upgrade to 7.7.3 and add py2/py3 subpackages
Diffstat (limited to 'main/py-phonenumbers/APKBUILD')
-rw-r--r--main/py-phonenumbers/APKBUILD54
1 files changed, 30 insertions, 24 deletions
diff --git a/main/py-phonenumbers/APKBUILD b/main/py-phonenumbers/APKBUILD
index ff689a057a9..60bce775f9e 100644
--- a/main/py-phonenumbers/APKBUILD
+++ b/main/py-phonenumbers/APKBUILD
@@ -2,40 +2,46 @@
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
pkgname=py-phonenumbers
_pkgname=phonenumbers
-pkgver=7.5.2
+pkgver=7.7.3
pkgrel=0
pkgdesc="International phone number library for Python"
-url=https://github.com/daviddrysdale/python-phonenumbers
+url="https://github.com/daviddrysdale/python-phonenumbers"
arch="noarch"
license="ASL 2.0"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
-md5sums="66a5b458d29c209456588499d3050f80 phonenumbers-7.5.2.tar.gz"
-sha256sums="66cef748ec45cc23add7cea3409a958eeb9d27ff0b5aac4b3c68ec861551d3ad phonenumbers-7.5.2.tar.gz"
-sha512sums="1a65dea60e50cc23a00ae3e1fdb8b0780964361a5ea9e9c1d71c01ed2edcd8573492d847ea23217e6c74aa7ddfad7a75fa0c8148462f2c8811da8891afd8be38 phonenumbers-7.5.2.tar.gz"
+md5sums="0b1a0f19a1f3544a55dd95e231f9ada8 phonenumbers-7.7.3.tar.gz"
+sha256sums="2d43be39f47ddf43e6d2ee45d8b7fbf4c808b8dbbe3f011dfb1c97775fe8e458 phonenumbers-7.7.3.tar.gz"
+sha512sums="886b46ee0bec028ec08d21f6be063c84e13281f6b3a79e3e712d717ae88b77a0b8820c7773cf47a1246bde2c8a1405a3cd292f625ecc63b3c623e71d18db2bc7 phonenumbers-7.7.3.tar.gz"