aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-simpleparse
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-06-08 06:59:13 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-06-08 07:00:50 +0000
commit5162ef95ee5af5f8ebf91ec27e15264091042967 (patch)
treef65b6d5241f8492851124cb2814601f9b8c3b295 /main/py-simpleparse
parent1537c57b016a729389583d1574a477921beffcab (diff)
testing/py-simpleparse: move to main
Diffstat (limited to 'main/py-simpleparse')
-rw-r--r--main/py-simpleparse/APKBUILD37
-rw-r--r--main/py-simpleparse/py-simpleparse-eols.patch33
2 files changed, 70 insertions, 0 deletions
diff --git a/main/py-simpleparse/APKBUILD b/main/py-simpleparse/APKBUILD
new file mode 100644
index 00000000000..da06bc68796
--- /dev/null
+++ b/main/py-simpleparse/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=py-simpleparse
+_realname=SimpleParse
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Python library providing simple and fast parser generator"
+url="http://launchpad.net/simpleparse"
+arch="all"
+license="BSD"
+depends="python"
+depends_dev="python-dev"
+makedepends="$depends_dev"
+install=
+subpackages=
+source="http://pypi.python.org/packages/source/S/$_realname/$_realname-$pkgver.zip
+ py-simpleparse-eols.patch"
+
+
+_builddir="$srcdir"/$_realname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ return 0
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --skip-build --root="$pkgdir"
+}
+
+md5sums="e58600b0db786664855cbd49dbc0e4e5 SimpleParse-2.1.1.zip
+b980d7400e2d5a97769330c5c2d927b3 py-simpleparse-eols.patch"
diff --git a/main/py-simpleparse/py-simpleparse-eols.patch b/main/py-simpleparse/py-simpleparse-eols.patch
new file mode 100644
index 00000000000..9fc1362243d
--- /dev/null
+++ b/main/py-simpleparse/py-simpleparse-eols.patch
@@ -0,0 +1,33 @@
+=== modified file 'examples/__init__.py'
+--- examples/__init__.py 2008-11-09 22:58:29 +0000
++++ examples/__init__.py 2011-08-17 18:31:28 +0000
+@@ -4,4 +4,4 @@
+ well as a demonstration of using "pre-built"
+ parser nodes (particularly one based on the re
+ module).
+-'''
+\ No newline at end of file
++'''
+
+=== modified file 'examples/simpleexample2_2.py'
+--- examples/simpleexample2_2.py 2008-11-09 22:58:29 +0000
++++ examples/simpleexample2_2.py 2011-08-17 20:06:58 +0000
+@@ -34,4 +34,4 @@
+ for testData in testEquality:
+ success, children, nextcharacter = parser.parse( testData, production=production)
+ assert success and nextcharacter==len(testData), """Wasn't able to parse %s as a %s (%s chars parsed of %s), returned value was %s"""%( repr(testData), production, nextcharacter, len(testData), (success, children, nextcharacter))
+-
+\ No newline at end of file
++
+
+=== modified file 'examples/vrml.py'
+--- examples/vrml.py 2008-11-09 22:58:29 +0000
++++ examples/vrml.py 2011-08-17 20:07:12 +0000
+@@ -57,4 +57,4 @@
+ success, tags, next = parser.parse( data)
+ d = time.time()-t
+ print "parsed %s characters of %s in %s seconds (%scps)"%( next, len(data), d, next/(d or 0.000000001) )
+-
+\ No newline at end of file
++
+