aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-fixtures/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-01-15 19:23:28 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-03-19 07:54:57 +0000
commit4dedadd080bb890cfbe70f33b4c94cf3f2064898 (patch)
treefc48c20ce9a339cfcda6b949634e53e764986d04 /main/py3-fixtures/APKBUILD
parent00c5a62861dd3fe2362f6425f7dfcf2ce38def6e (diff)
main/py3-fixtures: modernize and add missing dependency
It downloaded the missing dep from the network before
Diffstat (limited to 'main/py3-fixtures/APKBUILD')
-rw-r--r--main/py3-fixtures/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/main/py3-fixtures/APKBUILD b/main/py3-fixtures/APKBUILD
index 7d38b8db94e..e27b4890a35 100644
--- a/main/py3-fixtures/APKBUILD
+++ b/main/py3-fixtures/APKBUILD
@@ -1,17 +1,19 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-fixtures
-_pkgname=fixtures
pkgver=3.0.0
pkgrel=3
pkgdesc="Fixtures, reusable state for writing clean tests and more."
url="https://pypi.python.org/pypi/fixtures/"
arch="noarch"
license="MIT"
-depends="python3"
+depends="
+ py3-pbr
+ python3
+ "
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
+source="https://files.pythonhosted.org/packages/source/f/fixtures/fixtures-$pkgver.tar.gz"
+builddir="$srcdir/fixtures-$pkgver"
replaces="py-fixtures" # Backwards compatibility
provides="py-fixtures=$pkgver-r$pkgrel" # Backwards compatibility