aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-parsing/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-19 16:37:15 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-19 16:40:32 +0100
commit7254eea5207e7874d3503b283cfc0ce37673671f (patch)
tree4d5fd7ffbc132fd0a6d5d7df7eb77df25eb4a23a /main/py3-parsing/APKBUILD
parent8680de75147febd90e4031496690291caa30d6f3 (diff)
main/py3-parsing: drop python2
Diffstat (limited to 'main/py3-parsing/APKBUILD')
-rw-r--r--main/py3-parsing/APKBUILD34
1 files changed, 8 insertions, 26 deletions
diff --git a/main/py3-parsing/APKBUILD b/main/py3-parsing/APKBUILD
index 882c1e1b7f7..e9556ef33f1 100644
--- a/main/py3-parsing/APKBUILD
+++ b/main/py3-parsing/APKBUILD
@@ -1,45 +1,27 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=py-parsing
+pkgname=py3-parsing
_pkgname=pyparsing
pkgver=2.4.5
-pkgrel=0
+pkgrel=1
pkgdesc="An object-oriented approach to text processing"
url="http://pyparsing.wikispaces.com/"
arch="noarch"
license="MIT"
-makedepends="py2-setuptools py3-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-parsing" # Backwards compatibility
+provides="py-parsing=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="05563767c6a7be2cbb4755f0bc7b186fea962cd8629e7eaa82633472ce5fd76f8056c2a042c656d6b59cf7eeb0f9513f0abba87645b3b7da5562245ba31c87b5 pyparsing-2.4.5.tar.gz"