aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-ply/APKBUILD
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-04-16 01:29:53 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-30 12:38:37 +0000
commitd9319564d897d7b6b481f84ee98c45078ba79447 (patch)
tree9a3f1aba8e478ed848d3ee9222deb22be502f822 /main/py3-ply/APKBUILD
parente306e7f50da240fab2f71e0ac9561485bc48d298 (diff)
main/py3-ply: new aport
https://www.dabeaz.com/ply/ Python Lex & Yacc
Diffstat (limited to 'main/py3-ply/APKBUILD')
-rw-r--r--main/py3-ply/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/py3-ply/APKBUILD b/main/py3-ply/APKBUILD
new file mode 100644
index 00000000000..c5274e8f2a9
--- /dev/null
+++ b/main/py3-ply/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: tcely <py3-ply+aports@tcely.33mail.com>
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: tcely <py3-ply+aports@tcely.33mail.com>
+_pkgname='ply'
+pkgname="py3-$_pkgname"
+pkgver='3.11'
+pkgrel=0
+pkgdesc="Python Lex & Yacc"
+url="https://www.dabeaz.com/ply/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+checkdepends="py3-six"
+makedepends="python3-dev"
+install=""
+subpackages=""
+source="${_pkgname}-${pkgver}.tar.gz::https://github.com/dabeaz/${_pkgname}/archive/${pkgver}.tar.gz"
+builddir="${srcdir}/${_pkgname}-${pkgver}"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHON=python3 make test
+
+ cd test
+ python3 testcpp.py
+}
+
+package() {
+ #pip3 install --ignore-installed --root "$pkgdir" .
+ python3 setup.py install --prefix="/usr" --root="$pkgdir"
+}
+
+sha512sums="c36e4ea0eb5bb7cca8cc34aa62dd711be755e44f1336a0093d7c9c1ea4d5d8cae8316416a2109ba24bb2b71f7a971b0b34a7ea45c43d4c7c63c513156945fc17 ply-3.11.tar.gz"