aboutsummaryrefslogtreecommitdiffstats
path: root/main/py3-twitter/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-15 01:44:48 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-18 10:32:40 +0000
commitc936ade6c8cd50883ea49c7c2d54c170e144fc6b (patch)
treeb3f0b18dc51fcc32218b2e72daec8a7e4d94a62d /main/py3-twitter/APKBUILD
parent45265f0b0435ef179e6cc1e32d6ad4b790533d5f (diff)
main/py3-twitter: drop py2
Diffstat (limited to 'main/py3-twitter/APKBUILD')
-rw-r--r--main/py3-twitter/APKBUILD38
1 files changed, 10 insertions, 28 deletions
diff --git a/main/py3-twitter/APKBUILD b/main/py3-twitter/APKBUILD
index b192a73bfe8..3d447cc97e0 100644
--- a/main/py3-twitter/APKBUILD
+++ b/main/py3-twitter/APKBUILD
@@ -1,47 +1,29 @@
# Maintainer: prspkt <prspkt@protonmail.com>
-pkgname=py-twitter
+pkgname=py3-twitter
_pkgname=python-twitter
pkgver=3.5
-pkgrel=1
-pkgdesc="Python wrapper around the Twitter API"
+pkgrel=2
+pkgdesc="Python3 wrapper around the Twitter API"
+options="!check" # Requires 'pytest-runner' which is in community
url="https://pypi.python.org/pypi/python-twitter"
arch="noarch"
license="Apache-2.0"
-depends="py-future py-requests py-requests-oauthlib"
-makedepends="python2-dev py-setuptools python3-dev"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+depends="python3 py3-future py3-requests py3-requests-oauthlib"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-twitter" # Backwards compatibility
+provides="py-twitter=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="6ccd5aa81ec433a86a8d4db0fe28ab12d4b434849e2d06ae3cd70449d98fd642d4c16221113f4b6fd82610093c11ea042118cab0a876e4ec1208b0c8e14b41b5 python-twitter-3.5.tar.gz"