summaryrefslogtreecommitdiffstats
path: root/main/qemu
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2012-09-10 17:26:10 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2012-09-10 17:26:10 +0200
commit367bda76fc240ee05dda4b4af8d26a130bd709b0 (patch)
tree52ddeba1149a3a7ad4db203b5e1fe7bad4e5c027 /main/qemu
parent093f6785025f5c4ab6fe47c265633d3a9a290e6c (diff)
main/qemu: upgrade to 1.2.0
Diffstat (limited to 'main/qemu')
-rw-r--r--main/qemu/APKBUILD15
-rw-r--r--main/qemu/configure-properly-check-if-lrt-and-lm-is-needed.patch (renamed from main/qemu/0001-configure-properly-check-if-lrt-and-lm-is-needed.patch)41
2 files changed, 24 insertions, 32 deletions
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 135137bb28d..9ca165f2e52 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
-pkgver=1.1.1
+pkgver=1.2.0
pkgrel=0
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://qemu,org/"
@@ -35,12 +35,13 @@ $pkgname-sparc64
$pkgname-x86_64
$pkgname-xtensa
$pkgname-xtensaeb
+$pkgname-or32
+$pkgname-unicore32
$pkgname-img
"
-source="http://wiki.qemu.org/download/qemu-$pkgver-1.tar.bz2
+source="http://wiki.qemu.org/download/qemu-$pkgver.tar.bz2
80-kvm.rules
- 0001-configure-properly-check-if-lrt-and-lm-is-needed.patch
- "
+ configure-properly-check-if-lrt-and-lm-is-needed.patch"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
@@ -120,6 +121,8 @@ sparc64() { _subsys sparc64; }
x86_64() { _subsys x86_64; }
xtensa() { _subsys xtensa; }
xtensaeb() { _subsys xtensaeb; }
+or32() { _subsys or32; }
+unicore32() { _subsys unicore32; }
img() {
pkgdesc="QEMU command line tool for manipulating disk images"
@@ -142,6 +145,6 @@ img() {
return $_err
}
-md5sums="32e7cf4453039ef7478b22a53623cfb0 qemu-1.1.1-1.tar.bz2
+md5sums="78eb1e984f4532aa9f2bdd3c127b5b61 qemu-1.2.0.tar.bz2
66660f143235201249dc0648b39b86ee 80-kvm.rules
-c8d39e6ac8e9e49bdf34efe652aae532 0001-configure-properly-check-if-lrt-and-lm-is-needed.patch"
+67656f53ede5b13badf134c01b5773dd configure-properly-check-if-lrt-and-lm-is-needed.patch"
diff --git a/main/qemu/0001-configure-properly-check-if-lrt-and-lm-is-needed.patch b/main/qemu/configure-properly-check-if-lrt-and-lm-is-needed.patch
index 22c26acec84..283d1063bbd 100644
--- a/main/qemu/0001-configure-properly-check-if-lrt-and-lm-is-needed.patch
+++ b/main/qemu/configure-properly-check-if-lrt-and-lm-is-needed.patch
@@ -1,7 +1,4 @@
-From 50b76c5a19f53d42e1b564068692c042a6b00c52 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 14 Jun 2012 11:03:25 +0000
-Subject: [PATCH] configure: properly check if -lrt and -lm is needed
+properly check if -lrt and -lm is needed
Fixes build against uClibc.
@@ -13,15 +10,9 @@ function in addition.
We also need check if -lm is needed for isnan().
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- Makefile | 4 ++--
- Makefile.target | 4 +---
- configure | 33 +++++++++++++++++++++++++++++++--
- 3 files changed, 34 insertions(+), 7 deletions(-)
diff --git a/Makefile b/Makefile
-index 32550cb..9dfa01a 100644
+index 1cd5bc8..f414291 100644
--- a/Makefile
+++ b/Makefile
@@ -35,7 +35,7 @@ configure: ;
@@ -33,17 +24,17 @@ index 32550cb..9dfa01a 100644
HELPERS-$(CONFIG_LINUX) = qemu-bridge-helper$(EXESUF)
-@@ -172,7 +172,7 @@ qemu-img-cmds.h: $(SRC_PATH)/qemu-img-cmds.hx
+@@ -172,7 +172,7 @@ fsdev/virtfs-proxy-helper$(EXESUF): LIBS += -lcap
+ qemu-img-cmds.h: $(SRC_PATH)/qemu-img-cmds.hx
$(call quiet-command,sh $(SRC_PATH)/scripts/hxtool -h < $< > $@," GEN $@")
- qapi-dir := $(BUILD_DIR)/qapi-generated
-qemu-ga$(EXESUF): LIBS = $(LIBS_QGA)
+qemu-ga$(EXESUF): LIBS = $(LIBS_QGA) $(LIBRT) $(LIBM)
- qemu-ga$(EXESUF): QEMU_CFLAGS += -I $(qapi-dir)
+ qemu-ga$(EXESUF): QEMU_CFLAGS += -I qga/qapi-generated
gen-out-type = $(subst .,-,$(suffix $@))
diff --git a/Makefile.target b/Makefile.target
-index 2907aad..d214d2c 100644
+index 7892a8d..1c3bf31 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -34,9 +34,7 @@ PROGS+=$(QEMU_PROGW)
@@ -58,10 +49,10 @@ index 2907aad..d214d2c 100644
config-target.h: config-target.h-timestamp
config-target.h-timestamp: config-target.mak
diff --git a/configure b/configure
-index c2366ee..f925973 100755
+index d97fd81..697946c 100755
--- a/configure
+++ b/configure
-@@ -102,6 +102,8 @@ audio_win_int=""
+@@ -126,6 +126,8 @@ audio_win_int=""
cc_i386=i386-pc-linux-gnu-gcc
libs_qga=""
debug_info="yes"
@@ -70,10 +61,11 @@ index c2366ee..f925973 100755
target_list=""
-@@ -2568,17 +2570,42 @@ fi
-
+@@ -2666,19 +2668,43 @@ EOF
+ fi
+ fi
- ##########################################
++##########################################
+# Do we need libm
+cat > $TMPC << EOF
+#include <math.h>
@@ -89,8 +81,8 @@ index c2366ee..f925973 100755
+ echo
+ exit 1
+fi
-+
-+##########################################
+
+ ##########################################
# Do we need librt
cat > $TMPC <<EOF
#include <signal.h>
@@ -115,7 +107,7 @@ index c2366ee..f925973 100755
fi
if test "$darwin" != "yes" -a "$mingw32" != "yes" -a "$solaris" != yes -a \
-@@ -3442,6 +3469,8 @@ echo "LIBS_TOOLS+=$libs_tools" >> $config_host_mak
+@@ -3581,6 +3607,8 @@ echo "LIBS_TOOLS+=$libs_tools" >> $config_host_mak
echo "EXESUF=$EXESUF" >> $config_host_mak
echo "LIBS_QGA+=$libs_qga" >> $config_host_mak
echo "POD2MAN=$POD2MAN" >> $config_host_mak
@@ -124,6 +116,3 @@ index c2366ee..f925973 100755
# generate list of library paths for linker script
---
-1.7.10.4
-