summaryrefslogtreecommitdiffstats
path: root/main/readline
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
commit2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd (patch)
treea63d3b3b1c89018b5419358eed5c2bb0acf1cd92 /main/readline
parente374901731eb35599bd6735de4dd38560e3a79b8 (diff)
move core/* to main/
added maintainer to several packages as well
Diffstat (limited to 'main/readline')
-rw-r--r--main/readline/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/readline/APKBUILD b/main/readline/APKBUILD
new file mode 100644
index 00000000000..3c26ba12749
--- /dev/null
+++ b/main/readline/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=readline
+_myver=6.0
+_patchver=003
+pkgver=${_myver}.${_patchver}
+pkgrel=0
+pkgdesc="GNU readline library"
+url="ftp://ftp.cwru.edu/pub/bash/"
+license="GPL"
+depends=
+makedepends="ncurses-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/readline/readline-6.0.tar.gz
+ ftp://ftp.gnu.org/gnu/readline/readline-6.0-patches/readline60-001
+ ftp://ftp.gnu.org/gnu/readline/readline-6.0-patches/readline60-002
+ ftp://ftp.gnu.org/gnu/readline/readline-6.0-patches/readline60-003
+ "
+
+build ()
+{
+ cd "$srcdir/$pkgname-$_myver"
+ for i in "$srcdir"/readline60-???; do
+ msg "Applying ${i##*/}"
+ patch -Np2 -i ${i} || return 1
+ done
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+
+ make SHLIB_LIBS=-lncurses || return 1
+ make DESTDIR="$pkgdir" install || return 1
+
+}
+md5sums="b7f65a48add447693be6e86f04a63019 readline-6.0.tar.gz
+85c01ea031ad38a179053c67186bafed readline60-001
+4fad2a4ce987e3101229d0c8dfb0cd80 readline60-002
+80967f663864983a889af2eb53aea177 readline60-003"