aboutsummaryrefslogtreecommitdiffstats
path: root/main/resourceproto/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 08:45:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 08:47:22 +0000
commit8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc (patch)
treee1bdd0bbb491926306c1e43e72dabbbe235f4b62 /main/resourceproto/APKBUILD
parent832a032dd3794c5cc3e67f4ee580e171996e8e29 (diff)
main/[various]: update config.sub (and remove charset.alias)
for musl build. the changes are automatically done based on previous build log errors, so this does not guarantee successful build, but is a required.
Diffstat (limited to 'main/resourceproto/APKBUILD')
-rw-r--r--main/resourceproto/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/resourceproto/APKBUILD b/main/resourceproto/APKBUILD
index 4e14da433f3..da14e1f28af 100644
--- a/main/resourceproto/APKBUILD
+++ b/main/resourceproto/APKBUILD
@@ -10,8 +10,15 @@ depends=""
makedepends=""
source="http://xorg.freedesktop.org//releases/individual/proto/$pkgname-$pkgver.tar.bz2"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build () {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -21,7 +28,7 @@ build () {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
md5sums="cfdb57dae221b71b2703f8e2980eaaf4 resourceproto-1.2.0.tar.bz2"