aboutsummaryrefslogtreecommitdiffstats
path: root/main/setxkbmap/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-16 18:52:00 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-16 18:52:00 +0000
commitced1e02903a233c6ca2a36e816cea9fd6946f0ed (patch)
tree17f52ace253ef6a4baaf0d2b81cba0aaeaee6ee9 /main/setxkbmap/APKBUILD
parent8bd4249e988a560cb63b28238f4ed10f46ee9a23 (diff)
[various]: update config.sub, and update apkbuild
Diffstat (limited to 'main/setxkbmap/APKBUILD')
-rw-r--r--main/setxkbmap/APKBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/main/setxkbmap/APKBUILD b/main/setxkbmap/APKBUILD
index 766cc56971d..4f88a0755b7 100644
--- a/main/setxkbmap/APKBUILD
+++ b/main/setxkbmap/APKBUILD
@@ -10,16 +10,26 @@ depends=
makedepends="pkgconfig libxkbfile-dev"
source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
-build ()
-{
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+build() {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
|| return 1
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR=""$pkgdir"" install || return 1
}
md5sums="2f902e0a89aaf2b19e06e7f26c6efb3a setxkbmap-1.1.0.tar.bz2"
+sha256sums="932f2b314a4bf6dfccd16d63c633073abf650d8e136f481904e972ef3d4faf64 setxkbmap-1.1.0.tar.bz2"
+sha512sums="ca006e59b097c4cbb3434dc84eef3e0fcfb25af0f6a2b85b900a2db11c471592cd206ff048c3b8887d6e4bf48aa9168ed12f4e54b5b3b16d10ca8aa6a189ae45 setxkbmap-1.1.0.tar.bz2"