aboutsummaryrefslogtreecommitdiffstats
path: root/main/snort/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-07-20 08:51:15 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-07-20 08:51:23 +0000
commit119f1b40d38e640b559d3d5e7851b48161da9615 (patch)
tree2299d43304c154e9e5ef9932ea0aff221dd00af0 /main/snort/APKBUILD
parentbc19a64d36ea41143bab410652f9f50263b9df95 (diff)
main/snort: add a default config file
Diffstat (limited to 'main/snort/APKBUILD')
-rw-r--r--main/snort/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/main/snort/APKBUILD b/main/snort/APKBUILD
index 6f407d89a1e..2e59cd3f9e5 100644
--- a/main/snort/APKBUILD
+++ b/main/snort/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=snort
pkgver=2.9.3
-pkgrel=0
+pkgrel=1
pkgdesc="An open source network intrusion prevention and detection system"
url="http://www.snort.org/"
arch="all"
@@ -17,8 +17,10 @@ source="http://www.snort.org/dl/snort-current/snort-$pkgver.tar.gz
snort.confd
"
+_builddir="$srcdir/$pkgname-$pkgver"
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
# fix parallel builds
sed -i -e 's/^all-local:.*/all-local: $(LTLIBRARIES)/' \
@@ -35,13 +37,14 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/lib/*/*.la \
"$pkgdir"/usr/lib/snort/*/*.la || return 1
install -D -m 755 ../snort.initd "$pkgdir"/etc/init.d/snort
install -D -m 644 ../snort.confd "$pkgdir"/etc/conf.d/snort
+ install -D -m 644 etc/snort.conf "$pkgdir"/etc/snort/snort.conf
}
md5sums="e128f5d5d14dad335dc0c549c7fe2e98 snort-2.9.3.tar.gz