summaryrefslogtreecommitdiffstats
path: root/main/squashfs-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-12-02 10:39:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-12-02 10:39:00 +0000
commitd14ba6107e7837d93c1141cdcfd5ee8a3a6a8590 (patch)
tree46cd2c36245178ad6525a8ac37ec027fdc3ccd64 /main/squashfs-tools
parent7fcf64719e536a81e2c451b20c1c765e96ba150f (diff)
main/squashfs-tools: new aport
Tools for squashfs, a highly compressed read-only filesystem for Linux http://squashfs.sourceforge.net
Diffstat (limited to 'main/squashfs-tools')
-rw-r--r--main/squashfs-tools/APKBUILD26
-rw-r--r--main/squashfs-tools/squashfs-tools-4.0-uclibc-get_nprocs.patch22
2 files changed, 48 insertions, 0 deletions
diff --git a/main/squashfs-tools/APKBUILD b/main/squashfs-tools/APKBUILD
new file mode 100644
index 00000000000..8af448562f2
--- /dev/null
+++ b/main/squashfs-tools/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=squashfs-tools
+pkgver=4.0
+pkgrel=0
+pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
+url="http://squashfs.sourceforge.net"
+license="GPL"
+depends=
+makedepends="zlib-dev"
+source="http://downloads.sourceforge.net/sourceforge/squashfs/squashfs$pkgver.tar.gz
+ squashfs-tools-4.0-uclibc-get_nprocs.patch"
+
+build() {
+ cd "$srcdir"/squashfs$pkgver/$pkgname
+ patch -p2 -i "$srcdir"/squashfs-tools-4.0-uclibc-get_nprocs.patch \
+ || return 1
+ make
+}
+
+package() {
+ cd "$srcdir"/squashfs$pkgver/$pkgname
+ mkdir -p "$pkgdir"/sbin
+ cp -a mksquashfs unsquashfs "$pkgdir"/sbin
+}
+md5sums="a3c23391da4ebab0ac4a75021ddabf96 squashfs4.0.tar.gz
+761580c100eeffb60ebbda62d724bd3f squashfs-tools-4.0-uclibc-get_nprocs.patch"
diff --git a/main/squashfs-tools/squashfs-tools-4.0-uclibc-get_nprocs.patch b/main/squashfs-tools/squashfs-tools-4.0-uclibc-get_nprocs.patch
new file mode 100644
index 00000000000..9c6312f16bb
--- /dev/null
+++ b/main/squashfs-tools/squashfs-tools-4.0-uclibc-get_nprocs.patch
@@ -0,0 +1,22 @@
+--- a/squashfs-tools/mksquashfs.c Wed Dec 2 10:30:31 2009
++++ b/squashfs-tools/mksquashfs.c Wed Dec 2 10:31:34 2009
+@@ -3705,7 +3705,7 @@
+ processors = 1;
+ }
+ #else
+- processors = get_nprocs();
++ processors = sysconf(_SC_NPROCESSORS_ONLN);
+ #endif
+ }
+
+--- a/squashfs-tools/unsquashfs.c Wed Dec 2 10:30:31 2009
++++ b/squashfs-tools/unsquashfs.c Wed Dec 2 10:31:34 2009
+@@ -1811,7 +1811,7 @@
+ processors = 1;
+ }
+ #else
+- processors = get_nprocs();
++ processors = sysconf(_SC_NPROCESSORS_ONLN);
+ #endif
+ }
+