aboutsummaryrefslogtreecommitdiffstats
path: root/main/swig
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-07 18:40:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-07 18:40:50 +0000
commitfd605d093920fea6b6220e817b6e07c2858fddf9 (patch)
tree6980cbb07137ab33d38c37fc1ad95b65a7e913f9 /main/swig
parenteecc871f8ac20711406bbdd46db60b38e9874cbd (diff)
main/swig: new aport
SWIG is a compiler that makes it easy to integrate C and C++ code with scripting languages http://www.swig.org/
Diffstat (limited to 'main/swig')
-rw-r--r--main/swig/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/main/swig/APKBUILD b/main/swig/APKBUILD
new file mode 100644
index 00000000000..21587995c51
--- /dev/null
+++ b/main/swig/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=swig
+pkgver=1.3.39
+pkgrel=0
+pkgdesc="SWIG is a compiler that makes it easy to integrate C and C++ code with scripting languages"
+url="http://www.swig.org/"
+license="custom"
+depends="guile"
+makedepends="zlib-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums="ac201d1b87f8659584534f9540d7ad24 swig-1.3.39.tar.gz"