aboutsummaryrefslogtreecommitdiffstats
path: root/main/tcpflow/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-08-06 20:01:05 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-08-06 20:01:05 +0000
commit83a331f69304f37736fd00903b0137cbc1eadc47 (patch)
tree90677541b4181d029b0ac12e3e0473b8c531fbed /main/tcpflow/APKBUILD
parentc5ea113f75f540704403d16d8ec6007d39c077f2 (diff)
main/tcpflow: minor changes
Diffstat (limited to 'main/tcpflow/APKBUILD')
-rw-r--r--main/tcpflow/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/main/tcpflow/APKBUILD b/main/tcpflow/APKBUILD
index 0c5de2607a2..6278f2d5e0c 100644
--- a/main/tcpflow/APKBUILD
+++ b/main/tcpflow/APKBUILD
@@ -2,29 +2,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tcpflow
pkgver=1.2.8
-pkgrel=0
+pkgrel=1
pkgdesc="A Tool for monitoring, capturing and storing TCP connections flows"
url="https://github.com/simsong/tcpflow/wiki/tcpflow-%E2%80%94-A-tcp-ip-session-reassembler"
arch="all"
-license="GPL"
-depends=
+license="GPL3"
+depends=""
makedepends="libpcap-dev"
-install=
+install=""
subpackages="$pkgname-doc"
-source="https://github.com/downloads/simsong/tcpflow/tcpflow-1.2.8.tar.gz"
+source="https://github.com/downloads/simsong/tcpflow/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
-
- ./configure --prefix=/usr \
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
|| return 1
make || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
}
md5sums="6fa51c81fad9d836371903ab14b03f8c tcpflow-1.2.8.tar.gz"