aboutsummaryrefslogtreecommitdiffstats
path: root/main/tevent/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-09-07 15:21:22 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-09-08 09:05:17 +0000
commit8a5e5a1876297975cb5eb5335dc3676c1512219c (patch)
tree8f35f7f36eb7d16af651d79c5b9b77675c52385a /main/tevent/APKBUILD
parente605b86f3c117d9828b3565b346e529b69ed8fe5 (diff)
main/tevent: upgrade to 0.9.33, modernize and add check
Diffstat (limited to 'main/tevent/APKBUILD')
-rw-r--r--main/tevent/APKBUILD39
1 files changed, 15 insertions, 24 deletions
diff --git a/main/tevent/APKBUILD b/main/tevent/APKBUILD
index 1a32a01d12a..607c645a728 100644
--- a/main/tevent/APKBUILD
+++ b/main/tevent/APKBUILD
@@ -1,33 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tevent
-pkgver=0.9.32
+pkgver=0.9.33
pkgrel=0
pkgdesc="The tevent library"
url="http://tevent.samba.org/"
arch="all"
license="LGPLv3+"
-depends=""
-depends_dev=""
-makedepends="$depends_dev python2-dev talloc-dev"
+makedepends="python2-dev talloc-dev"
replaces="samba"
-install=""
subpackages="$pkgname-dev py-$pkgname:_py"
-source="http://samba.org/ftp/tevent/tevent-$pkgver.tar.gz
- "
+source="http://samba.org/ftp/tevent/tevent-$pkgver.tar.gz"
-_builddir="$srcdir"/tevent-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,14 +25,18 @@ build() {
--localstatedir=/var \
--disable-rpath \
--bundled-libraries=NONE \
- --without-gettext \
- || return 1
- make || return 1
+ --without-gettext
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
_py() {
@@ -54,4 +45,4 @@ _py() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-sha512sums="9bd256c245d9f82dcd5b31787c8b11780b958bef96426de231f54eaea6df680a5cf3eb8c8d066d05f271e81f303404fc4191a23a6bc2533b7d1b732b2c206fbd tevent-0.9.32.tar.gz"
+sha512sums="3a437957859a556e06f24334301c41a3db1433c1e90d651fa74585a638a36d71369f235a8ab51aa0dd8f9d9bb88ad42f2c3ddeba0b99c4234c63866a8c922b91 tevent-0.9.33.tar.gz"