aboutsummaryrefslogtreecommitdiffstats
path: root/main/thunar/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-30 07:41:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-30 09:27:16 +0000
commit2a9ef96d439dd086681adfc83be64e5d4637e7b4 (patch)
treec9218187a272256d349fb2ebc91fca96c78dc534 /main/thunar/APKBUILD
parent7211ae8f1de75b87c7b0ebf8b12ae5109eae0f65 (diff)
main/thunar: clean up deps. enable gtk-doc
Diffstat (limited to 'main/thunar/APKBUILD')
-rw-r--r--main/thunar/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/main/thunar/APKBUILD b/main/thunar/APKBUILD
index a95c1821640..4ca80622b9a 100644
--- a/main/thunar/APKBUILD
+++ b/main/thunar/APKBUILD
@@ -1,22 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=thunar
pkgver=1.6.3
-pkgrel=0
+pkgrel=1
pkgdesc="File manager for Xfce"
url="http://thunar.xfce.org"
arch="all"
license="GPL2 LGPL2"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
depends="desktop-file-utils hicolor-icon-theme shared-mime-info"
-makedepends="libexif-dev xfce4-panel-dev exo-dev pcre-dev udev-dev
- libnotify-dev startup-notification-dev libxfce4ui-dev dbus-glib-dev"
+depends_dev="gtk+-dev glib-dev exo-dev"
+makedepends="$depends_dev libexif-dev xfce4-panel-dev pcre-dev udev-dev
+ libnotify-dev startup-notification-dev libxfce4ui-dev dbus-glib-dev
+ gtk-doc"
install=
source="http://archive.xfce.org/src/xfce/thunar/${pkgver%.*}/Thunar-$pkgver.tar.bz2
thunar-sendto-audacious-playlist.desktop
thunar-sendto-bluetooth.desktop
"
-depends_dev="gtk+-dev glib-dev exo-dev"
_builddir="$srcdir"/Thunar-$pkgver
prepare() {
@@ -41,6 +42,7 @@ build() {
--enable-dbus \
--enable-gio-unix \
--enable-gudev \
+ --enable-gtk-doc \
|| return 1
make || return 1
}