summaryrefslogtreecommitdiffstats
path: root/main/tmux/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
commitb70981b68efcce5256eb11c6cd26ae123b10b6ea (patch)
treea38be6efae5e2ba15c2e839504632f9b7bfd5f91 /main/tmux/APKBUILD
parent2b4df81538b8398442d5296650905c70341dd8d3 (diff)
moved extra/* to main/
and fixed misc build issues
Diffstat (limited to 'main/tmux/APKBUILD')
-rw-r--r--main/tmux/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/main/tmux/APKBUILD b/main/tmux/APKBUILD
new file mode 100644
index 00000000000..7edc932264c
--- /dev/null
+++ b/main/tmux/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=tmux
+pkgver=0.9
+pkgrel=0
+pkgdesc="Tool to control multiple terminals from a single terminal"
+url="http://tmux.sourceforge.net/"
+license="BSD"
+depends=""
+makedepends="ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ build.patch"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < ../build.patch || return 1
+
+ ./configure
+ make || return 1
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+
+}
+
+md5sums="2d1df646a6977bb7d9b20e53770d5593 tmux-0.9.tar.gz
+373cabbc35601c3ee71fde0877f5fe83 build.patch"