aboutsummaryrefslogtreecommitdiffstats
path: root/main/usbredir/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-05 00:01:28 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-05 00:01:28 -0300
commit00f962281a0993d32d76f51bd85cb9de9cdf814e (patch)
treebc1dec07ef49d949349ad258964049f12f33d47f /main/usbredir/APKBUILD
parent39450ccf86c5a948d3ce29e7ee047ac526c89439 (diff)
main/usbredir: modernize
Diffstat (limited to 'main/usbredir/APKBUILD')
-rw-r--r--main/usbredir/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/main/usbredir/APKBUILD b/main/usbredir/APKBUILD
index 9c3956b125b..004c69b28da 100644
--- a/main/usbredir/APKBUILD
+++ b/main/usbredir/APKBUILD
@@ -1,18 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=usbredir
pkgver=0.8.0
-pkgrel=0
+pkgrel=1
pkgdesc="USB network redirection protocol libraries"
-url="http://spice-space.org/page/UsbRedir"
+url="https://www.spice-space.org/usbredir.html"
arch="all"
options="!check" # No test suite.
-license="GPL-2.0-or-later LGPL-2.1-or-later"
+license="GPL-2.0-or-later AND LGPL-2.1-or-later"
makedepends="libusb-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-server"
-source="https://www.spice-space.org/download/$pkgname/$pkgname-$pkgver.tar.bz2"
+source="https://www.spice-space.org/download/usbredir/usbredir-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -26,12 +25,10 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
check() {
- cd "$builddir"
make check
}