aboutsummaryrefslogtreecommitdiffstats
path: root/main/util-linux/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-07-30 08:45:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-30 12:50:50 +0000
commita6b01b1a79486042a6ff781fce55d1e376d81c4d (patch)
tree513d6ae3213bbc982b0dbeeebd8f42c5fde83ed9 /main/util-linux/APKBUILD
parent8a06eb58e5e8e050b08a560f43b55b30ea9e2692 (diff)
main/util-linux: upgrade to 2.23.1
and normalize ./configure call
Diffstat (limited to 'main/util-linux/APKBUILD')
-rw-r--r--main/util-linux/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index c6cc23317a4..6b7b69f7400 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=util-linux
-pkgver=2.22.2
+pkgver=2.23.1
case $pkgver in
*.*.*) _v=${pkgver%.*};;
@@ -20,7 +20,6 @@ install=
source="http://www.kernel.org/pub/linux/utils/util-linux/v${_v}/util-linux-$pkgver.tar.xz
program-invocation.patch
gentoo-no-scanf.patch
- rpmatch.patch
"
subpackages="$pkgname-doc $pkgname-dev libuuid libblkid sfdisk cfdisk mcookie blkid"
replaces="e2fsprogs util-linux-ng"
@@ -40,12 +39,15 @@ prepare() {
build() {
cd "$_builddir"
-# sed -e 's/versionsort/alphasort/g'\
+# sed -e 's/versionsort/alphasort/g' \
# -e 's/strverscmp.h/dirent.h/g' \
# -i mount/lomount.c
# login utils are provided by shadow (with PAM) or busybox (no PAM) --nenolod
- ./configure --prefix=/usr \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
--enable-raw \
--disable-uuidd \
--disable-nls \
@@ -116,7 +118,12 @@ mcookie() {
mv "$pkgdir"/usr/bin/mcookie "$subpkgdir"/usr/bin/
}
-md5sums="eeacbfdd2556acd899a2d0ffdb446185 util-linux-2.22.2.tar.xz
+md5sums="33ba55ce82f8e3b8d7a38fac0f62779a util-linux-2.23.1.tar.xz
9682a6ddd5abe65434a145ebe512c123 program-invocation.patch
-85125e2cc7d54dc2733bedc603886f81 gentoo-no-scanf.patch
-2e6d6835adc6e962249d1c11792649fa rpmatch.patch"
+85125e2cc7d54dc2733bedc603886f81 gentoo-no-scanf.patch"
+sha256sums="76fe4c11cf69f4293a676a61eb92710771f7514fd603d7192411b89bbf50d4e6 util-linux-2.23.1.tar.xz
+2bfa27969effc77631e981bbbcd1bf261e61f3e51875db950883ddb2a90ea4fd program-invocation.patch
+2a2429b59151a63a75d2ff46f60732c6a3fbe9b52e472802edcf4eedbe3e22f2 gentoo-no-scanf.patch"
+sha512sums="bbe3cb82c35a78331067ce098396acabf83599d7061e3b8ddc063411327dca8ba0ba4e1b258a25d6a37a124342f381dd77c7e70c04adb508f6ddc18e437cd73f util-linux-2.23.1.tar.xz
+5a07e86fa84961f73e53677d202e7a2101704eacb698426e62da897af07c7f1227e841f79ff59deed50cfb0e9ef1816f7c3fd03382ae4aa46909b6cd41a95d4e program-invocation.patch
+5f199511d3c6919c1a23248f2fd1d15343ee330e169b8440ca48bbbbc1aae243d8bd652ab504520c5d12dd0875e5e94a704d727d4b71bcd940d4ff51115b3981 gentoo-no-scanf.patch"