aboutsummaryrefslogtreecommitdiffstats
path: root/main/uwsgi
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-11 16:43:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-11 16:45:25 +0000
commitb29a9c6b71d98426bbb5368b547ae4b01c7e0067 (patch)
tree70d0923f84260137e28009f135e2028266af1ab5 /main/uwsgi
parent711677eed8f2978146a73ec4ff2afac7be6d9b2d (diff)
main/uwsgi: fix permissions of log and socket dir
enable group write permissions to socket dir and to log dir so clidren have the permissions to create sockets and logfiles create the log directory from apk
Diffstat (limited to 'main/uwsgi')
-rw-r--r--main/uwsgi/APKBUILD18
-rw-r--r--main/uwsgi/uwsgi.initd4
2 files changed, 6 insertions, 16 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index dd057070801..3c61d1d432e 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uwsgi
pkgver=2.0.14
-pkgrel=6
+pkgrel=7
pkgdesc="uWSGI application container server"
url="http://projects.unbit.it/uwsgi/"
arch="all"
@@ -176,6 +176,8 @@ package() {
install -m 755 -D "$srcdir"/uwsgi.initd \
"$pkgdir"/etc/init.d/uwsgi || return 1
+ install -m 775 -d -o root -g uwsgi "$pkgdir"/var/log/uwsgi
+
# Disable emutramp/mprotect, this is needed for luajit and cffi.
paxmark -em "$pkgdir"/usr/sbin/uwsgi
}
@@ -191,20 +193,8 @@ _plugin() {
"$subpkgdir"/usr/lib/uwsgi/${name}_plugin.so || return 1
}
-md5sums="d4b2c7db274dc20be54a977c9b040b7e uwsgi-2.0.14.tar.gz
-0e83db2a9324eaafa0ae46a572603f58 uwsgi.initd
-a797ffed638ea797a16557d963598fb2 uwsgi.ini
-cf4242f1a6cd8182a91d5c27dc688fe1 readme.emperor
-98407f45c566a2c39a34b882e1ac9fe4 alpine.buildconf
-87c16f6fe482c9b0eac0d33c51873f45 musl-fix-python.patch"
-sha256sums="21b3d1ef926d835ff23576193a2c60d4c896d8e21567850cf0677a4764122887 uwsgi-2.0.14.tar.gz
-b573d63d7ffefd27ea978bc4a9e9dce208217376dcbe526ce636e8fa55954021 uwsgi.initd
-b9cc5a3590b95854eb563fbb84b3e0f54d25ea6d222585a1b40583a6913cc911 uwsgi.ini
-bad9480a81d57baaef1d228713837f5dae81f93527c436aeb1ed5ed8dad58f54 readme.emperor
-31fc9c17f17aa067c3b025a3f7a84c6102d24368afcbc237f3d58041083c0875 alpine.buildconf
-3838e8e3926a1f6271bb5aa88d309837a3bcd06cd570c499b72ca549326c682e musl-fix-python.patch"
sha512sums="cf557ba27cb1c28e784e8909043bca874cd56846aa9ebaf1ff229191ad20484e467147a6ea7cc629399d4afd6e4ac4479b2f6827729df04321eef4bf842b9e42 uwsgi-2.0.14.tar.gz
-30ced9f9cb96bca7cc0019fab64fe746cb9f1a08b1d2f80429e715231fbc6b8e3b6e76c5cc24e1efef6168cb0f9dd826624e864046c2edf5b1f097df3c1cffda uwsgi.initd
+63137d45437e00deb970d66e2abddf7f235636b748f6cf545f54ff5557066c2a71db5c4a3bab2edceb4e65d3d7fac887f1f4c0e77658127e02b64d3026780b4c uwsgi.initd
370202e143d0e041a2e36905346080d3ca592c9a74705a8c4e142a1307d22b921c10e673d683ca284ea27d184474ed86edd7723a6e590d35a562ad7cf6afa529 uwsgi.ini
2798c9d2e49e29292ffe6a5a29b866301c78d5f322fc5d07dfa9569efdaa5220237a5f6744652fbdd957be29311ddaff190541333f042cbf0e907dfa98ce3e2a readme.emperor
f3cff00926929a5bb40afafb65fd5228582af35fbf524562282020c4c4ae9c659231b2381f4b3cceb18e8f3f6c888c21bdd8ed4ddcd81e92fbc6a0891800ce38 alpine.buildconf
diff --git a/main/uwsgi/uwsgi.initd b/main/uwsgi/uwsgi.initd
index cdef9f04925..69ab2da1930 100644
--- a/main/uwsgi/uwsgi.initd
+++ b/main/uwsgi/uwsgi.initd
@@ -59,8 +59,8 @@ start_pre() {
command_args="$command_args --yaml ${uwsgi_conf%.yml}.yml"
fi
- checkpath -d -m 755 -o $user:$group \
- "$(dirname "$pidfile")" "$(dirname "$logfile")"
+ checkpath -d -m 775 -o $user:$group \
+ "$(dirname "$pidfile")"
if yesno "$EINFO_VERBOSE"; then
einfo "Command: $command $(printf '%s ' $command_args)"