summaryrefslogtreecommitdiffstats
path: root/main/varnish
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-06-15 08:27:27 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-06-15 08:27:38 +0000
commitf3166b37956c87106d433d8314b2705f8efd0b91 (patch)
tree09be70e6e7219c76ff4aec68777ee36cbb5c3e52 /main/varnish
parentcfe93befa1f0680f648e8a90085da374932225cd (diff)
testing/varnish: move to main
Diffstat (limited to 'main/varnish')
-rw-r--r--main/varnish/APKBUILD65
-rw-r--r--main/varnish/varnishd.confd12
-rwxr-xr-xmain/varnish/varnishd.initd44
-rw-r--r--main/varnish/varnishd.logrotate9
4 files changed, 130 insertions, 0 deletions
diff --git a/main/varnish/APKBUILD b/main/varnish/APKBUILD
new file mode 100644
index 00000000000..0ac8b3c5205
--- /dev/null
+++ b/main/varnish/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=varnish
+pkgver=3.0.2
+pkgrel=5
+pkgdesc="High-performance HTTP accelerator"
+url="http://www.varnish-cache.org/"
+arch="all"
+license="BSD"
+depends="gcc uclibc-dev"
+depends_dev=
+makedepends="$depends_dev pcre-dev ncurses-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://repo.varnish-cache.org/source/varnish-$pkgver.tar.gz
+ varnishd.initd
+ varnishd.confd
+ varnishd.logrotate"
+
+_builddir="$srcdir"/varnish-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var/lib \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+ install -Dm755 "$srcdir"/varnishd.initd "$pkgdir"/etc/init.d/varnishd \
+ || return 1
+ install -Dm644 "$srcdir"/varnishd.confd "$pkgdir"/etc/conf.d/varnishd \
+ || return 1
+ install -Dm644 "$srcdir"/varnishd.logrotate \
+ "$pkgdir"/etc/logrotate.d/varnishd || return 1
+ mkdir -p "$pkgdir"/var/log/varnish
+ find "$pkgdir" -name *.la -print | xargs rm
+}
+
+libs() {
+ pkgdesc="Libraries for varnish"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="c8eae0aabbe66b6daabdf3a1f58cd47a varnish-3.0.2.tar.gz
+78f4d4692757dec0d86987253d6b2e29 varnishd.initd
+69869d23bacd4e3aaf060d1fedb79ac6 varnishd.confd
+a6cb8a43c9465699cf956dc992998225 varnishd.logrotate"
diff --git a/main/varnish/varnishd.confd b/main/varnish/varnishd.confd
new file mode 100644
index 00000000000..ebce5948ca9
--- /dev/null
+++ b/main/varnish/varnishd.confd
@@ -0,0 +1,12 @@
+# /etc/conf.d/varnishd
+
+ADMINHOSTPORT="127.0.0.1:65080"
+CFG_FILE="/etc/varnish/default.vcl"
+
+# options passed to varnish on startup
+# please see the varnishd man page for more options
+VARNISHD_OPTS="-a 127.0.0.1:8080 -b 127.0.0.1:80 -T $ADMINHOSTPORT"
+
+# arguments passed to varnishncsa
+# please see the varnishncsa man page for more options
+VARNISHNCSA_ARGS="-c -a -w /var/log/varnish/access.log"
diff --git a/main/varnish/varnishd.initd b/main/varnish/varnishd.initd
new file mode 100755
index 00000000000..2ed5b751d45
--- /dev/null
+++ b/main/varnish/varnishd.initd
@@ -0,0 +1,44 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/files/varnishd.initd,v 1.7 2009/08/30 06:28:07 hollow Exp $
+
+extra_command=reload
+NOW=`date +%s`
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting varnish"
+ #allow varnishd to lock logfile to memory
+ ulimit -l 82000
+ start-stop-daemon --quiet --start --pidfile /var/run/varnishd.pid --exec /usr/sbin/varnishd -- -P /var/run/varnishd.pid ${VARNISHD_OPTS} &> /dev/null
+ eend $?
+
+ if [ "${VARNISHNCSA_ARGS}" != "" ]; then
+ ebegin "Starting varnish logging"
+ start-stop-daemon --quiet --start --pidfile /var/run/varnishncsa.pid --exec /usr/bin/varnishncsa -- -D -P /var/run/varnishncsa.pid ${VARNISHNCSA_ARGS}
+ eend $?
+ fi
+}
+
+stop() {
+ ebegin "Stopping varnish"
+ start-stop-daemon --quiet --stop --pidfile /var/run/varnishd.pid
+ eend $?
+
+ if [ -e /var/run/varnishncsa.pid ]; then
+ ebegin "Stopping varnish logging"
+ start-stop-daemon --quiet --stop --pidfile /var/run/varnishncsa.pid
+ eend $?
+ fi
+}
+
+reload() {
+ ebegin "Reloading varnish"
+ /usr/bin/varnishadm -T $ADMINHOSTPORT vcl.load reload$NOW $CFG_FILE
+ /usr/bin/varnishadm -T $ADMINHOSTPORT vcl.use reload$NOW $CFG_FILE
+ eend $?
+}
diff --git a/main/varnish/varnishd.logrotate b/main/varnish/varnishd.logrotate
new file mode 100644
index 00000000000..62ee60007a2
--- /dev/null
+++ b/main/varnish/varnishd.logrotate
@@ -0,0 +1,9 @@
+/var/log/varnish/*.log {
+ weekly
+ rotate 10
+ copytruncate
+ delaycompress
+ compress
+ notifempty
+ missingok
+}