summaryrefslogtreecommitdiffstats
path: root/main/wine/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-09 08:33:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-09 08:33:17 +0000
commit0ffb8fd99cbb3535ad5469c4bf17b624c2461dbc (patch)
tree30f70a5dc90d289558bd7675260533cb9ff9cbb3 /main/wine/APKBUILD
parent0627b86c85a90e1fc2c8267c4c24ffb48d2a8a45 (diff)
main/wine: enable win64
no 32bit support for now.
Diffstat (limited to 'main/wine/APKBUILD')
-rw-r--r--main/wine/APKBUILD27
1 files changed, 22 insertions, 5 deletions
diff --git a/main/wine/APKBUILD b/main/wine/APKBUILD
index cc3a908fe81..68af75d576d 100644
--- a/main/wine/APKBUILD
+++ b/main/wine/APKBUILD
@@ -2,10 +2,10 @@
pkgname=wine
pkgver=1.7.28
_ver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="A compatibility layer for running Windows programs"
url="http://www.winehq.com"
-arch="x86"
+arch="x86 x86_64"
license="LGPL2+"
subpackages="$pkgname-dev $pkgname-doc"
makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
@@ -37,22 +37,39 @@ prepare() {
build() {
cd "$_builddir"
+
+ case "$CARCH" in
+ x86_64) _win64=--enable-win64;;
+ esac
+
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
+ --libdir=/usr/lib \
--with-dbus \
--with-x \
+ $_win64 \
|| return 1
make
}
package() {
cd "$_builddir"
- make -j1 prefix="$pkgdir"/usr install || return 1
+ make -j1 \
+ prefix="$pkgdir"/usr \
+ libdir="$pkgdir"/usr/lib \
+ dlldir="$pkgdir"/usr/lib/wine \
+ install || return 1
mkdir -p "$pkgdir"/etc/wine
- paxctl -c -psmre "$pkgdir"/usr/bin/wine-preloader \
- "$pkgdir"/usr/bin/wine
+
+ case "$CARCH" in
+ x86_64) _wine="wine64";;
+ *)_wine="wine";;
+ esac
+
+ paxctl -c -psmre "$pkgdir"/usr/bin/$_wine-preloader \
+ "$pkgdir"/usr/bin/$_wine
}
md5sums="7443e04f368a63de80ec2738f5337abd wine-1.7.28.tar.bz2