summaryrefslogtreecommitdiffstats
path: root/main/wpa_supplicant
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-17 10:05:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-17 10:05:16 +0000
commit6797087d494f8707be1236bb1e420e60af35b903 (patch)
tree1afd711fd117a1cc831b8a6a5bbf9b7917b8207e /main/wpa_supplicant
parent3698511c9263be69e0a7ea16b135d75438e63601 (diff)
main/wpa_supplicant: fix init.d script and move config
Diffstat (limited to 'main/wpa_supplicant')
-rw-r--r--main/wpa_supplicant/APKBUILD10
-rw-r--r--main/wpa_supplicant/wpa_supplicant.initd2
2 files changed, 7 insertions, 5 deletions
diff --git a/main/wpa_supplicant/APKBUILD b/main/wpa_supplicant/APKBUILD
index a79805c9072..62695bf7117 100644
--- a/main/wpa_supplicant/APKBUILD
+++ b/main/wpa_supplicant/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wpa_supplicant
pkgver=0.7.2
-pkgrel=0
+pkgrel=1
pkgdesc="A utility providing key negotiation for WPA wireless networks"
url="http://hostap.epitest.fi/wpa_supplicant"
license="GPL"
@@ -91,15 +91,17 @@ prepare() {
build() {
cd "$_builddir"
make LIBDIR=/lib BINDIR=/sbin || return 1
+ # comment out the network={ } stansas in config
+ sed -i -e '/^network=/,/}/s/^/#/' wpa_supplicant.conf
}
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" LIBDIR=/lib BINDIR=/sbin install || return 1
- install -Dm644 wpa_supplicant.conf "$pkgdir"/etc/wpa_supplicant.conf
+ install -Dm644 wpa_supplicant.conf \
+ "$pkgdir"/etc/wpa_supplicant/wpa_supplicant.conf
install -Dm644 doc/docbook/wpa_supplicant.conf.5 \
"$pkgdir"/usr/share/man/man5/wpa_supplicant.conf.5 || return 1
-
for i in wpa_background wpa_cli wpa_passphrase wpa_supplicant; do
install -Dm644 doc/docbook/$i.8 \
"$pkgdir"/usr/share/man/man8/$i.8 || return 1
@@ -120,5 +122,5 @@ package() {
"$pkgdir"/etc/conf.d/wpa_supplicant || return 1
}
md5sums="0e2cb7e4c35667351d8b7ec28c783e6a wpa_supplicant-0.7.2.tar.gz
-6185ecb6aecef66310cdd23fb3fb7d0c wpa_supplicant.initd
+55f853354f51ba947e4dd6ee2bb0d64a wpa_supplicant.initd
bc117427f2c538439f3f1481a028ee06 wpa_supplicant.confd"
diff --git a/main/wpa_supplicant/wpa_supplicant.initd b/main/wpa_supplicant/wpa_supplicant.initd
index 8429a373384..7a9949b8beb 100644
--- a/main/wpa_supplicant/wpa_supplicant.initd
+++ b/main/wpa_supplicant/wpa_supplicant.initd
@@ -2,7 +2,7 @@
# Copyright (c) 2009 Roy Marples <roy@marples.name>
# All rights reserved. Released under the 2-clause BSD license.
-command=/usr/sbin/wpa_supplicant
+command=/sbin/wpa_supplicant
: ${wpa_supplicant_conf:=/etc/wpa_supplicant/wpa_supplicant.conf}
wpa_supplicant_if=${wpa_supplicant_if:+-i}$wpa_supplicant_if
command_args="$wpa_supplicant_args -B -c$wpa_supplicant_conf $wpa_supplicant_if"