aboutsummaryrefslogtreecommitdiffstats
path: root/main/xcb-util-image
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-29 11:08:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-29 11:10:02 +0000
commitc13b60219d61101f075fc54e80c7f49d2ffe34b3 (patch)
tree445332e87761aa21635595fe1c0cf1ef6871f516 /main/xcb-util-image
parent63f11ecc1eb75aab15eceb6fd50958256767991a (diff)
main/xcb-util-image: upgrade to 0.4.0
Diffstat (limited to 'main/xcb-util-image')
-rw-r--r--main/xcb-util-image/APKBUILD23
-rw-r--r--main/xcb-util-image/fix-c90-warnings-2.patch28
-rw-r--r--main/xcb-util-image/fix-c90-warnings.patch33
-rw-r--r--main/xcb-util-image/fix-return.patch46
4 files changed, 5 insertions, 125 deletions
diff --git a/main/xcb-util-image/APKBUILD b/main/xcb-util-image/APKBUILD
index e8f0d5a81aa..e2be56f4a13 100644
--- a/main/xcb-util-image/APKBUILD
+++ b/main/xcb-util-image/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xcb-util-image
-pkgver=0.3.9
-pkgrel=1
+pkgver=0.4.0
+pkgrel=0
pkgdesc="Utility libraries for XC Binding - image"
url="http://xcb.freedesktop.org/"
arch="all"
@@ -14,16 +14,12 @@ install=""
replaces="xcb-util"
subpackages="$pkgname-dev"
source="http://xcb.freedesktop.org/dist/xcb-util-image-$pkgver.tar.gz
- fix-return.patch
- fix-c90-warnings.patch
- fix-c90-warnings-2.patch
"
_builddir="$srcdir"/xcb-util-image-$pkgver
prepare() {
local i
cd "$_builddir"
- update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -52,15 +48,6 @@ package() {
rm "$pkgdir"/usr/lib/*.la
}
-md5sums="0bdfcea4ce0666b45d2d64c1f1e25801 xcb-util-image-0.3.9.tar.gz
-92a43b07efef0450bf65838a65793580 fix-return.patch
-268dde6f747d697f80c2daa351f40633 fix-c90-warnings.patch
-8a934c04a513efdbfeaadd65229ccc7f fix-c90-warnings-2.patch"
-sha256sums="ac7fa09eddc9ecda6fd872d32b6dc23d451a1c6c201873dfe7cac8362c87acf3 xcb-util-image-0.3.9.tar.gz
-05a16fb3ae61bd1e02cc3c55f24ab677865ab514c0935151af63e58b647ac515 fix-return.patch
-aa0413a24bdb4954e01a68ba235199c64e38f6ba18ac8440f25f28bb265fd10c fix-c90-warnings.patch
-55c9d781997eaec1b0c10819b8211321a6e15ea472af7687e9cb93988f4aa12c fix-c90-warnings-2.patch"
-sha512sums="f4b6a8c39dcb63273627655dd5b99fcf6d9d5d1cd32ec57589e8fa3ac04c043548c615f60a2d9673d38e9ce0e1b56cf51a17c55669c7b37e48d9054474ae4090 xcb-util-image-0.3.9.tar.gz
-12c9d36375e42c127fd0e50363b5289cfa86ec238f94af9914e1a5375e55180fe37645a7cc473ff19c286c84dfdee74b6bdb7c3aa6ae1f3d0f0608e482d4c76c fix-return.patch
-1df9fd7fd6e8c0802635f8034b43a77766dddf7b7fb868c5788caf3073798e3ded8c1b6e1baace88fe742d0ea86e1da71f8c77b069242e15d5bf13c1bd82768f fix-c90-warnings.patch
-d9406550a1da9de117a77284888464e6de88908de386b2e0c24b6e33c30cc1d0b975665d10b67e75b464d88878c0d794682f0e10ab160271f8b2a5cad735293e fix-c90-warnings-2.patch"
+md5sums="32c9c2f72ebd58a2b2e210f27fee86f7 xcb-util-image-0.4.0.tar.gz"
+sha256sums="cb2c86190cf6216260b7357a57d9100811bb6f78c24576a3a5bfef6ad3740a42 xcb-util-image-0.4.0.tar.gz"
+sha512sums="2e580d205e4a054763146c70d735014c7e018322a43c76b07a306c091dca81b140cbbf6db41252e9204ff742f119b69e143b3fdc1fb13bd9d0b9e8e22eda2cd3 xcb-util-image-0.4.0.tar.gz"
diff --git a/main/xcb-util-image/fix-c90-warnings-2.patch b/main/xcb-util-image/fix-c90-warnings-2.patch
deleted file mode 100644
index dfce4966859..00000000000
--- a/main/xcb-util-image/fix-c90-warnings-2.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- xcb-util-image-0.3.9.orig/image/xcb_image.c
-+++ xcb-util-image-0.3.9/image/xcb_image.c
-@@ -324,6 +324,11 @@
- case XCB_IMAGE_FORMAT_XY_PIXMAP:
- plane_mask &= xcb_mask(imrep->depth);
- if (plane_mask != xcb_mask(imrep->depth)) {
-+ int i;
-+ uint32_t rpm = plane_mask;
-+ uint8_t * src_plane = image->data;
-+ uint8_t * dst_plane;
-+ uint32_t size = image->height * image->stride;
- xcb_image_t * tmp_image =
- xcb_image_create_native(conn, width, height, format,
- imrep->depth, 0, 0, 0);
-@@ -333,12 +338,7 @@
- return 0;
- }
-
-- int i;
-- uint32_t rpm = plane_mask;
-- uint8_t * src_plane = image->data;
-- uint8_t * dst_plane = tmp_image->data;
-- uint32_t size = image->height * image->stride;
--
-+ dst_plane = tmp_image->data;
- if (tmp_image->bit_order == XCB_IMAGE_ORDER_MSB_FIRST)
- rpm = xcb_bit_reverse(plane_mask, imrep->depth);
- for (i = 0; i < imrep->depth; i++) {
diff --git a/main/xcb-util-image/fix-c90-warnings.patch b/main/xcb-util-image/fix-c90-warnings.patch
deleted file mode 100644
index f9cfa85b6c7..00000000000
--- a/main/xcb-util-image/fix-c90-warnings.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 7c2c36a1472941353a700bbac7dc351a92f42258 Mon Sep 17 00:00:00 2001
-From: Bart Massey <bart@cs.pdx.edu>
-Date: Fri, 23 Aug 2013 23:45:36 +0000
-Subject: fixed some compiler C90 warnings
-
----
-diff --git a/image/test_xcb_image_shm.c b/image/test_xcb_image_shm.c
-index 76f7f71..3162a6e 100644
---- a/image/test_xcb_image_shm.c
-+++ b/image/test_xcb_image_shm.c
-@@ -58,6 +58,9 @@ main (int argc, char *argv[])
- int screen_nbr;
- xcb_generic_event_t *e;
- uint8_t format;
-+ xcb_image_t *img;
-+ xcb_shm_query_version_reply_t *rep;
-+ xcb_shm_segment_info_t shminfo;
-
- /* Open the connexion to the X server and get the first screen */
- c = xcb_connect (NULL, &screen_nbr);
-@@ -81,10 +84,6 @@ main (int argc, char *argv[])
-
- /* Shm test */
- printf ("shm test begin\n");
-- xcb_image_t *img = 0;
-- xcb_shm_query_version_reply_t *rep;
-- xcb_shm_segment_info_t shminfo;
--
- rep = xcb_shm_query_version_reply (c,
- xcb_shm_query_version (c),
- NULL);
---
-cgit v0.9.0.2-2-gbebe
diff --git a/main/xcb-util-image/fix-return.patch b/main/xcb-util-image/fix-return.patch
deleted file mode 100644
index d1ebc397a94..00000000000
--- a/main/xcb-util-image/fix-return.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 3577db110e03985d4486cae6caf3ceb5696c45e9 Mon Sep 17 00:00:00 2001
-From: Jon TURNEY <jon.turney@dronecode.org.uk>
-Date: Thu, 20 Dec 2012 22:56:28 +0000
-Subject: Fix compilation when NDEBUG is defined
-
-XORG_DEFAULT_OPTIONS enables -Werror=return-type
-
-xcb_image_get_pixel() and xcb_image_create_native() assume assert(0) is
-noreturn, and don't return a value in that case. But assert(0) isn't noreturn
-if NDEBUG is defined.
-
-Fix this by returning a suitable value.
-
-(Also, on the MinGW target, assert(0) is non-standard and may return even in the
-!NDEBUG case, as the C runtime may ask the user if they want to abort or not...)
-
-/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c: In function 'xcb_image_get_pixel':
-/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c:754:1: error: control reaches end of non-void function [-Wreturn-type]
-/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c: In function 'xcb_image_create_native':
-/jhbuild/checkout/xcb/xcb-util-image/image/xcb_image.c:190:1: error: control reaches end of non-void function [-Wreturn-type]
-
-Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk>
-Signed-off-by: Peter Harris <pharris@opentext.com>
----
-diff --git a/image/xcb_image.c b/image/xcb_image.c
-index e426cbd..101aa4f 100644
---- a/image/xcb_image.c
-+++ b/image/xcb_image.c
-@@ -187,6 +187,7 @@ xcb_image_create_native (xcb_connection_t * c,
- assert(0);
- }
- assert(0);
-+ return NULL;
- }
-
-
-@@ -751,6 +752,7 @@ xcb_image_get_pixel (xcb_image_t *image,
- default:
- assert(0);
- }
-+ return 0;
- }
-
-
---
-cgit v0.9.0.2-2-gbebe