aboutsummaryrefslogtreecommitdiffstats
path: root/main/xcb-util/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-04 23:52:15 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-04 23:52:21 -0300
commitf8f8e8e235308f855a0b109cc03e062144ae746e (patch)
tree03713e04789dbc6a3f397f078192a3f6aed69930 /main/xcb-util/APKBUILD
parent0995c6915e73082bc55f45f1326b20a7a209ea53 (diff)
main/xcb-util: fix url and license
Diffstat (limited to 'main/xcb-util/APKBUILD')
-rw-r--r--main/xcb-util/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/main/xcb-util/APKBUILD b/main/xcb-util/APKBUILD
index d8bd5a67666..cb0c0f0926a 100644
--- a/main/xcb-util/APKBUILD
+++ b/main/xcb-util/APKBUILD
@@ -1,20 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xcb-util
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Utility libraries for X C-language Binding"
-url="http://xcb.freedesktop.org"
+url="https://gitlab.freedesktop.org/xorg/lib/libxcb-cursor"
arch="all"
-license="GPL"
+license="MIT"
depends_dev="libxcb-dev util-macros"
makedepends="$depends_dev m4 gperf"
checkdepends="check-dev"
subpackages="$pkgname-dev"
-source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://xcb.freedesktop.org/dist/xcb-util-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,12 +22,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}