summaryrefslogtreecommitdiffstats
path: root/main/xf86-video-dummy/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/xf86-video-dummy/APKBUILD
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
merged x11 repository into main
ref #255
Diffstat (limited to 'main/xf86-video-dummy/APKBUILD')
-rw-r--r--main/xf86-video-dummy/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/main/xf86-video-dummy/APKBUILD b/main/xf86-video-dummy/APKBUILD
new file mode 100644
index 00000000000..b8f5570fd6c
--- /dev/null
+++ b/main/xf86-video-dummy/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-dummy
+pkgver=0.3.3
+pkgrel=0
+pkgdesc="X.Org driver for dummy cards"
+url="http://xorg.freedesktop.org/"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="pkgconfig xorg-server-dev libxi-dev fontsproto randrproto
+ videoproto renderproto xf86dgaproto"
+
+source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="3ffe3a28f4452e66bf56180e7da9cbc5 xf86-video-dummy-0.3.3.tar.bz2"