aboutsummaryrefslogtreecommitdiffstats
path: root/main/xf86-video-rendition
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-07 10:09:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-07 18:23:45 +0000
commit36f423d8c9ba57bab678980ef26af9ffde755485 (patch)
tree89b4fccf96db0071832b61311ee10ee447635026 /main/xf86-video-rendition
parentef357e8740832b3571354dc27ce96c32c259af45 (diff)
main/xf86-video-rendition: rebuild against xorg-server-1.14
Diffstat (limited to 'main/xf86-video-rendition')
-rw-r--r--main/xf86-video-rendition/APKBUILD12
-rw-r--r--main/xf86-video-rendition/mibstore.patch35
2 files changed, 44 insertions, 3 deletions
diff --git a/main/xf86-video-rendition/APKBUILD b/main/xf86-video-rendition/APKBUILD
index 8b09d882413..e2d02188a55 100644
--- a/main/xf86-video-rendition/APKBUILD
+++ b/main/xf86-video-rendition/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-rendition
pkgver=4.2.5
-pkgrel=1
+pkgrel=3
pkgdesc="Rendition video driver"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -11,7 +11,8 @@ depends=
makedepends="pkgconfig xorg-server-dev libxi-dev fontsproto randrproto
videoproto renderproto"
-source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
+ mibstore.patch"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
@@ -35,4 +36,9 @@ package() {
rm "$pkgdir"/usr/lib/xorg/modules/*/*.la || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="6db439a0f89e6f00c4f5175510d8e0c1 xf86-video-rendition-4.2.5.tar.bz2"
+md5sums="6db439a0f89e6f00c4f5175510d8e0c1 xf86-video-rendition-4.2.5.tar.bz2
+bf6125aff3bcce84b6d289c1b8ae510b mibstore.patch"
+sha256sums="39b5569338237de6e17b2a2c6be73ac6c405ee596079c41a7028cfd6e54134cb xf86-video-rendition-4.2.5.tar.bz2
+93a59e9deed98af201c8bb231fdf3214fcd02dae8ef2f880b044b4fd100cdb4c mibstore.patch"
+sha512sums="203529e2a9c917362ac7c9b4247a9a0a4a7e1911bd022a26b00f467ec4cfd9ce742465aba29618cbfaa5ac5ff0b43e5a54f651e45e81aa950776685e4f74ba72 xf86-video-rendition-4.2.5.tar.bz2
+f05cfc55def69453152d2f45d50cadb5641601cd7f7f8a197482a7ea6cfbec271c5872cdfff3fc3c9dea9a878990a4a943685c383095d925e17641a3c4a2acba mibstore.patch"
diff --git a/main/xf86-video-rendition/mibstore.patch b/main/xf86-video-rendition/mibstore.patch
new file mode 100644
index 00000000000..77c4d34dea0
--- /dev/null
+++ b/main/xf86-video-rendition/mibstore.patch
@@ -0,0 +1,35 @@
+From 3a3ee1c45e54a808947cc26ca11f0a5299571053 Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 25 Sep 2012 12:54:50 +0000
+Subject: Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+diff --git a/src/rendition.c b/src/rendition.c
+index 7c74f76..888bb4a 100644
+--- a/src/rendition.c
++++ b/src/rendition.c
+@@ -1173,7 +1173,6 @@ renditionScreenInit(SCREEN_INIT_ARGS_DECL)
+ fbPictureInit (pScreen, 0, 0);
+
+ xf86SetBlackWhitePixels(pScreen);
+- miInitializeBackingStore(pScreen);
+
+ /*********************************************************/
+ /* The actual setup of the driver-specific code */
+diff --git a/src/rendition.h b/src/rendition.h
+index f7f13d4..297117e 100644
+--- a/src/rendition.h
++++ b/src/rendition.h
+@@ -28,9 +28,6 @@
+ /* All drivers initialising the SW cursor need this */
+ #include "mipointer.h"
+
+-/* All drivers implementing backing store need this */
+-#include "mibstore.h"
+-
+ /* All drivers using the mi colormap manipulation need this */
+ #include "micmap.h"
+
+--
+cgit v0.9.0.2-2-gbebe