summaryrefslogtreecommitdiffstats
path: root/main/xfce4-battery-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/xfce4-battery-plugin
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
merged x11 repository into main
ref #255
Diffstat (limited to 'main/xfce4-battery-plugin')
-rw-r--r--main/xfce4-battery-plugin/APKBUILD30
-rw-r--r--main/xfce4-battery-plugin/compile_x86_64.diff13
l---------main/xfce4-battery-plugin/xfce4-battery-plugin.post-deinstall1
-rw-r--r--main/xfce4-battery-plugin/xfce4-battery-plugin.post-install4
l---------main/xfce4-battery-plugin/xfce4-battery-plugin.post-upgrade1
5 files changed, 49 insertions, 0 deletions
diff --git a/main/xfce4-battery-plugin/APKBUILD b/main/xfce4-battery-plugin/APKBUILD
new file mode 100644
index 00000000000..c0b271cff65
--- /dev/null
+++ b/main/xfce4-battery-plugin/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-battery-plugin
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="A battery monitor plugin for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+license="GPL-2"
+makedepends="xfce4-panel-dev libxfcegui4-dev perl-xml-parser intltool"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
+source="http://goodies.xfce.org/releases/$pkgname/$pkgname-$pkgver.tar.bz2
+ compile_x86_64.diff
+ $install"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/compile_x86_64.diff || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="d8a666d85bb3c1dd007b547de4dd7037 xfce4-battery-plugin-0.5.1.tar.bz2
+d9a927bca032e9b10a04046c154243a1 compile_x86_64.diff
+db51db79681eadc47be4932355a77c25 xfce4-battery-plugin.post-install
+db51db79681eadc47be4932355a77c25 xfce4-battery-plugin.post-upgrade
+db51db79681eadc47be4932355a77c25 xfce4-battery-plugin.post-deinstall"
diff --git a/main/xfce4-battery-plugin/compile_x86_64.diff b/main/xfce4-battery-plugin/compile_x86_64.diff
new file mode 100644
index 00000000000..102db1d9567
--- /dev/null
+++ b/main/xfce4-battery-plugin/compile_x86_64.diff
@@ -0,0 +1,13 @@
+--- xfce4-battery-plugin-0.5.0/panel-plugin/libapm.h.orig 2008-03-18 20:10:58.000000000 +0100
++++ xfce4-battery-plugin-0.5.0/panel-plugin/libapm.h 2008-03-18 20:14:45.000000000 +0100
+@@ -17,8 +17,8 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-#include <linux/apm_bios.h>
+ #include <sys/types.h>
++#include <linux/apm_bios.h>
+
+ #define APM_PROC "/proc/apm"
+ #define APM_DEVICE "/dev/apm_bios"
+
diff --git a/main/xfce4-battery-plugin/xfce4-battery-plugin.post-deinstall b/main/xfce4-battery-plugin/xfce4-battery-plugin.post-deinstall
new file mode 120000
index 00000000000..ffd189d10c7
--- /dev/null
+++ b/main/xfce4-battery-plugin/xfce4-battery-plugin.post-deinstall
@@ -0,0 +1 @@
+xfce4-battery-plugin.post-install \ No newline at end of file
diff --git a/main/xfce4-battery-plugin/xfce4-battery-plugin.post-install b/main/xfce4-battery-plugin/xfce4-battery-plugin.post-install
new file mode 100644
index 00000000000..c523d78da07
--- /dev/null
+++ b/main/xfce4-battery-plugin/xfce4-battery-plugin.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
diff --git a/main/xfce4-battery-plugin/xfce4-battery-plugin.post-upgrade b/main/xfce4-battery-plugin/xfce4-battery-plugin.post-upgrade
new file mode 120000
index 00000000000..ffd189d10c7
--- /dev/null
+++ b/main/xfce4-battery-plugin/xfce4-battery-plugin.post-upgrade
@@ -0,0 +1 @@
+xfce4-battery-plugin.post-install \ No newline at end of file