summaryrefslogtreecommitdiffstats
path: root/main/xfce4-notes-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-29 15:47:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-29 15:47:47 +0000
commit5c47b9f79cd17d97ba4f91eb665dd0df3014e840 (patch)
tree340836e8ade7c860517f351fb4b1ad08264632ea /main/xfce4-notes-plugin
parent3acb14e008f0b7f56d5185eae23c452cf431e576 (diff)
main/xfce4-notes-plugin: moved from aports
Diffstat (limited to 'main/xfce4-notes-plugin')
-rw-r--r--main/xfce4-notes-plugin/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/xfce4-notes-plugin/APKBUILD b/main/xfce4-notes-plugin/APKBUILD
new file mode 100644
index 00000000000..42e7ccd175e
--- /dev/null
+++ b/main/xfce4-notes-plugin/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor:
+# Maintainer:
+pkgname=xfce4-notes-plugin
+pkgver=1.7.2
+pkgrel=0
+pkgdesc="Notes plugin for the Xfce4 desktop"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
+license="GPL"
+depends=
+makedepends="xfce4-panel-dev libunique-dev"
+install=
+subpackages=
+source="http://archive.xfce.org/src/panel-plugins/xfce4-notes-plugin/1.7/xfce4-notes-plugin-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="054742ecc4bb83de6c1447b023938d3e xfce4-notes-plugin-1.7.2.tar.bz2"