aboutsummaryrefslogtreecommitdiffstats
path: root/main/yaml/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-10-03 23:35:04 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-10-03 23:35:36 +0200
commita853e3bc421a520fccd5b482e92f1584ab9b25af (patch)
treed785046f70aa97a09f69169e6f12d08f8ce47993 /main/yaml/APKBUILD
parent1cb9a3c256d076b67ad03c2815cd8f79a33a50f4 (diff)
main/yaml: upgrade to 0.1.7
Diffstat (limited to 'main/yaml/APKBUILD')
-rw-r--r--main/yaml/APKBUILD35
1 files changed, 9 insertions, 26 deletions
diff --git a/main/yaml/APKBUILD b/main/yaml/APKBUILD
index 1d7aad34729..bf0718e1fdf 100644
--- a/main/yaml/APKBUILD
+++ b/main/yaml/APKBUILD
@@ -1,34 +1,20 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=yaml
-pkgver=0.1.6
-pkgrel=1
+pkgver=0.1.7
+pkgrel=0
pkgdesc="YAML 1.1 parser and emitter written in C"
url="http://pyyaml.org/wiki/LibYAML"
arch="all"
license="MIT"
depends=""
makedepends=""
-install=""
subpackages="$pkgname-dev"
-source="http://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz
- CVE-2014-9130.patch
- "
-
-_builddir="$srcdir"/yaml-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="http://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz"
+builddir="$srcdir/yaml-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,13 +28,10 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="5fe00cda18ca5daeb43762b80c38e06e yaml-0.1.6.tar.gz
-ec710ccf96476c5eff3eba2e412560d5 CVE-2014-9130.patch"
-sha256sums="7da6971b4bd08a986dd2a61353bc422362bd0edcc67d7ebaac68c95f74182749 yaml-0.1.6.tar.gz
-4255081c22c7e823dc77967efcbcb2493cac991fca3648c7d825c1bc3c25d2fa CVE-2014-9130.patch"
-sha512sums="eef1f26fec0a305836b8c6a65def4e2864fe2415618e7490717d4e42f0fc51048727ab0e7e4a6c3a2783ae762fddd6b78091a76a6cd3a2710ae18e3dfb27cd44 yaml-0.1.6.tar.gz
-1d6e7db8b45ba4edc3d0b89951113c908c65f7477630ab3c046d4eddc1533eb32b9840d9dbe65704c9f70958e6eeb214fdbb6f393f3fdcae011aaf09bc4c5e97 CVE-2014-9130.patch"
+md5sums="1abf45bd3a96374fa55ca63b32f9f2f9 yaml-0.1.7.tar.gz"
+sha256sums="8088e457264a98ba451a90b8661fcb4f9d6f478f7265d48322a196cec2480729 yaml-0.1.7.tar.gz"
+sha512sums="1ee5007dd10db137b5ee80f8117f07390ec04af98d087a5f5475dd2b38d87c699b79ab1676e6c7bfa263323fcdf8edd69fada2b0b7f9c57bef4e46cd65f1e975 yaml-0.1.7.tar.gz"