summaryrefslogtreecommitdiffstats
path: root/main/zsh/APKBUILD
diff options
context:
space:
mode:
authorkalonji <lonkaji@gmail.com>2011-01-02 12:49:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-03 14:55:23 +0000
commit0344b8067393c6d7fe0311ace3454ad4e71f2c1e (patch)
tree84ceea92fa21cb764a5b245e3f83262568aa9c01 /main/zsh/APKBUILD
parent89e9c4d33ab73f9c486a0a3bed1f25f8a9b6ed22 (diff)
Committer: kalonji <lonkaji@gmail.com> new aport: zsh shell
new file: APKBUILD new file: zsh.post-install new file: zsh.post-upgrade new file: zsh.pre-deinstall
Diffstat (limited to 'main/zsh/APKBUILD')
-rw-r--r--main/zsh/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/main/zsh/APKBUILD b/main/zsh/APKBUILD
new file mode 100644
index 00000000000..413b122459a
--- /dev/null
+++ b/main/zsh/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: <kalonji@gmail.com>
+# Maintainer: <kalonji@gmail.com>
+pkgname=zsh
+pkgver=4.3.11
+pkgrel=1
+pkgdesc="A very advanced and programmable command interpreter (shell) for UNIX"
+url="http://www.zsh.org/"
+license="custom"
+depends=
+makedepends=ncurses-dev
+install="zsh.post-install zsh.post-upgrade zsh.pre-deinstall"
+source="ftp://ftp.zsh.org/pub/${pkgname}-${pkgver}.tar.gz
+$install"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --bindir=/bin \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zlogin=/etc/zsh/zlogin \
+ --enable-zlogout=/etc/zsh/zlogout \
+ --enable-zprofile=/etc/profile \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-multibyte \
+ --enable-function-subdirs \
+ --enable-zsh-secure-free \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="127e2a3b9100d6f2fddb6a32cd4aca40 zsh-4.3.11.tar.gz
+aedff0460ef282937905223207ac702e zsh.post-install
+aedff0460ef282937905223207ac702e zsh.post-upgrade
+b48f79e2d4a29047f6152f5a9441f942 zsh.pre-deinstall"