summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-11 04:46:49 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-11 04:46:49 -0600
commit15126fceda8ef9a920cd84a52ec607e8caa98092 (patch)
treeb80f305812182335f219733a993928f7e249ec73 /main
parentd0612ac7d3d787bf913c4662dd08ec35badfe72b (diff)
main/mesa: do not install everything on mesa-dev
Diffstat (limited to 'main')
-rw-r--r--main/mesa/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index e0327919ee2..2dcd346c85b 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
pkgver=7.10.1
-pkgrel=0
+pkgrel=1
pkgdesc="Mesa DRI OpenGL library"
url="http://www.mesa3d.org"
arch="all"
@@ -54,6 +54,11 @@ prepare() {
done
}
+dev() {
+ default_dev;
+ depends="$depends_dev"
+}
+
build() {
cd "$_builddir"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"