aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-08-25 14:03:00 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-09-16 19:12:29 +0000
commitf08b0ba8e2292ecc8cf736efb61499362dfffa9a (patch)
treed75876f7a74b2521aea8d5e662fae55c304857b9 /main
parent3dc7774a7ae11eaaf2518e8d231de4f765c645c7 (diff)
main/geoip: remove cron
See: #12950
Diffstat (limited to 'main')
-rw-r--r--main/geoip/APKBUILD11
-rwxr-xr-xmain/geoip/geoip.cron7
2 files changed, 5 insertions, 13 deletions
diff --git a/main/geoip/APKBUILD b/main/geoip/APKBUILD
index dcde2c3a593..245a56315e1 100644
--- a/main/geoip/APKBUILD
+++ b/main/geoip/APKBUILD
@@ -2,15 +2,14 @@
pkgname="geoip"
_pkgname="GeoIP"
pkgver=1.6.12
-pkgrel=1
+pkgrel=2
pkgdesc="Lookup countries by IP addresses"
url="http://www.maxmind.com/app/ip-location"
arch="all"
license="GPL"
makedepends="zlib-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/maxmind/geoip-api-c/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz
- geoip.cron"
+source="https://github.com/maxmind/geoip-api-c/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
@@ -29,7 +28,6 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/GeoIP
- install -m755 -D ../../geoip.cron "$pkgdir"/etc/periodic/monthly/geoip
}
check() {
@@ -37,5 +35,6 @@ check() {
make check
}
-sha512sums="a1c8120692a7ba6de5836550917f86f4797dd236a8b7d71b6f92b5389e4b071d89e57036654f5de1d4b762730a2a5c331c31414eab0c889c9befaa097941fee7 GeoIP-1.6.12.tar.gz
-910b1efc93898416057aa7fc1a3f57d35f354973656ed40fbe266c737c4b4aa37f28b42e4163ed850a454c999bc880c27d863a04a14328b7b7e65348a85dd7d3 geoip.cron"
+sha512sums="
+a1c8120692a7ba6de5836550917f86f4797dd236a8b7d71b6f92b5389e4b071d89e57036654f5de1d4b762730a2a5c331c31414eab0c889c9befaa097941fee7 GeoIP-1.6.12.tar.gz
+"
diff --git a/main/geoip/geoip.cron b/main/geoip/geoip.cron
deleted file mode 100755
index 8d74aff5cf6..00000000000
--- a/main/geoip/geoip.cron
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-wget -q http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz -O /tmp/GeoIP.dat.gz && gunzip /tmp/GeoIP.dat.gz && mv /tmp/GeoIP.dat /usr/share/GeoIP
-wget -q http://geolite.maxmind.com/download/geoip/database/GeoIPv6.dat.gz -O /tmp/GeoIPv6.dat.gz && gunzip /tmp/GeoIPv6.dat.gz && mv /tmp/GeoIPv6.dat /usr/share/GeoIP
-wget -q http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz -O /tmp/GeoLiteCity.dat.gz && gunzip /tmp/GeoLiteCity.dat.gz && mv /tmp/GeoLiteCity.dat /usr/share/GeoIP
-wget -q http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz -O /tmp/GeoLiteCityv6.dat.gz && gunzip /tmp/GeoLiteCityv6.dat.gz && mv /tmp/GeoLiteCityv6.dat /usr/share/GeoIP
-wget -q http://geolite.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz -O /tmp/GeoIPASNum.dat.gz && gunzip /tmp/GeoIPASNum.dat.gz && mv /tmp/GeoIPASNum.dat /usr/share/GeoIP
-wget -q http://geolite.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz -O /tmp/GeoIPASNumv6.dat.gz && gunzip /tmp/GeoIPASNumv6.dat.gz && mv /tmp/GeoIPASNumv6.dat /usr/share/GeoIP