summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-10 12:30:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-10 12:30:16 +0000
commit2e17521140965d34b4c816a0ce6fda4300abbe15 (patch)
tree35712b35c6708545cbc862d83136013ce99e9960 /main
parentbb175cd5b8b4f2ea8bf37e8a2b2a3091bd4889cf (diff)
main/dovecot: hide dl errors
like they do for openbsd. ref #1274
Diffstat (limited to 'main')
-rw-r--r--main/dovecot/2281223b9cb9.patch21
-rw-r--r--main/dovecot/APKBUILD11
-rw-r--r--main/dovecot/hide-dl-errors.patch11
3 files changed, 21 insertions, 22 deletions
diff --git a/main/dovecot/2281223b9cb9.patch b/main/dovecot/2281223b9cb9.patch
deleted file mode 100644
index 4eb9c01f85f..00000000000
--- a/main/dovecot/2281223b9cb9.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-
-# HG changeset patch
-# User Timo Sirainen <tss@iki.fi>
-# Date 1281449944 -3600
-# Node ID 2281223b9cb99357a89971b64680530813d22a81
-# Parent 367ce71922bfc95ec1faad91cd47f1c758cd2d50
-master: Don't crash on config reload when using dict processes.
-
---- a/src/master/dict-process.c Wed Aug 04 16:54:17 2010 +0100
-+++ b/src/master/dict-process.c Tue Aug 10 15:19:04 2010 +0100
-@@ -214,7 +214,8 @@
- struct dict_listener *listener = process->listener;
-
- dict_process_deinit(process);
-- if (listener->processes == NULL && listener->fd != -1) {
-+ if (listener->processes == NULL && listener->fd != -1 &&
-+ listener->io == NULL) {
- /* last listener died, create new ones */
- listener->io = io_add(listener->fd, IO_READ,
- dict_listener_input, listener);
-
diff --git a/main/dovecot/APKBUILD b/main/dovecot/APKBUILD
index 74f75be6f09..c386c651423 100644
--- a/main/dovecot/APKBUILD
+++ b/main/dovecot/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dovecot
pkgver=2.1.10
-pkgrel=0
+pkgrel=1
pkgdesc="IMAP and POP3 server"
url="http://www.dovecot.org/"
arch="all"
@@ -16,7 +16,11 @@ install="dovecot.pre-install dovecot.post-install"
subpackages="$pkgname-sample-config:config $pkgname-doc $pkgname-dev
$pkgname-pgsql $pkgname-mysql $pkgname-sqlite $pkgname-gssapi
$pkgname-ldap"
+patches="
+ hide-dl-errors.patch
+ "
source="http://www.dovecot.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.gz
+ $patches
dovecot.logrotate
dovecot.initd
dovecot-sample-config.post-install
@@ -24,6 +28,10 @@ source="http://www.dovecot.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.gz
prepare() {
cd "$srcdir"/$pkgname-$pkgver
+ for i in $patches; do
+ msg $i
+ patch -p1 -i "$srcdir"/$i || return 1
+ done
}
build() {
@@ -117,6 +125,7 @@ config() {
}
md5sums="a5a4b3c444cf37e2c6bb6df3af87e18e dovecot-2.1.10.tar.gz
+49f7a03284cc657857fe2ae22b8c82a0 hide-dl-errors.patch
aec5cc797ab2acf72ce3b6bb1030345f dovecot.logrotate
59f210c712284a82e3a65b4126ddd99c dovecot.initd
95cf57ecc835882228bbbb019ce3abf8 dovecot-sample-config.post-install"
diff --git a/main/dovecot/hide-dl-errors.patch b/main/dovecot/hide-dl-errors.patch
new file mode 100644
index 00000000000..ccc1360f93b
--- /dev/null
+++ b/main/dovecot/hide-dl-errors.patch
@@ -0,0 +1,11 @@
+--- ./src/lib/module-dir.c.orig
++++ ./src/lib/module-dir.c
+@@ -141,7 +141,7 @@
+
+ static void *quiet_dlopen(const char *path, int flags)
+ {
+-#ifndef __OpenBSD__
++#if !defined(__OpenBSD__) && !defined(__UCLIBC__)
+ return dlopen(path, flags);
+ #else
+ void *handle;