aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-07 08:15:50 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-07-07 08:15:50 +0000
commit1f0857f0481303fb62e947bb108b7efa441aee7b (patch)
tree34f0aaf262da7301ec27f74d66efed00ac530c50 /main
parente9b429f496a2b9b0891e6ecde82c35ab91ac9f0f (diff)
main/busybox: fix depmod binary index patch
fixes #7487
Diffstat (limited to 'main')
-rw-r--r--main/busybox/0007-depmod-support-generating-kmod-binary-index-files.patch17
-rw-r--r--main/busybox/APKBUILD4
2 files changed, 11 insertions, 10 deletions
diff --git a/main/busybox/0007-depmod-support-generating-kmod-binary-index-files.patch b/main/busybox/0007-depmod-support-generating-kmod-binary-index-files.patch
index ee4dfb1b759..8b89902debd 100644
--- a/main/busybox/0007-depmod-support-generating-kmod-binary-index-files.patch
+++ b/main/busybox/0007-depmod-support-generating-kmod-binary-index-files.patch
@@ -1,4 +1,4 @@
-From c7d6c398844aca9651b7f01edadd9a8284919c89 Mon Sep 17 00:00:00 2001
+From ab4df89615fc2c5726b4ce55546e4dc098211a0b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
Date: Sun, 25 Oct 2015 22:21:41 +0200
Subject: [PATCH 07/11] depmod: support generating kmod binary index files
@@ -15,18 +15,18 @@ the code size a little bit.
Signed-off-by: Timo Teräs <timo.teras@iki.fi>
---
- modutils/Config.src | 10 ++
+ modutils/Config.src | 9 ++
modutils/depmod.c | 281 ++++++++++++++++++++++++++++++++++++++++++----------
modutils/modprobe.c | 15 ---
modutils/modutils.c | 31 ++++++
- modutils/modutils.h | 15 +++
+ modutils/modutils.h | 16 +++
5 files changed, 286 insertions(+), 66 deletions(-)
diff --git a/modutils/Config.src b/modutils/Config.src
-index 9b76c83d2..5ab51d68b 100644
+index 9b76c83d2..9e3b9b71e 100644
--- a/modutils/Config.src
+++ b/modutils/Config.src
-@@ -152,6 +152,16 @@ config FEATURE_MODUTILS_ALIAS
+@@ -152,6 +152,15 @@ config FEATURE_MODUTILS_ALIAS
Say Y if unsure.
@@ -34,7 +34,6 @@ index 9b76c83d2..5ab51d68b 100644
+ bool "Support for the kmod .bin file format"
+ default n
+ depends on DEPMOD && !MODPROBE_SMALL
-+ select PLATFORM_LINUX
+ help
+ Generate kmod compatible binary index files for .dep, .alias,
+ .symbols and .builtin files. Allows mixing use of busybox
@@ -478,7 +477,7 @@ index 6f7cd9721..257089af4 100644
{
char *tok;
diff --git a/modutils/modutils.h b/modutils/modutils.h
-index 4a702e97c..c07d961bd 100644
+index 4a702e97c..73e816028 100644
--- a/modutils/modutils.h
+++ b/modutils/modutils.h
@@ -18,6 +18,20 @@ PUSH_AND_SET_FUNCTION_VISIBILITY_TO_HIDDEN
@@ -502,14 +501,16 @@ index 4a702e97c..c07d961bd 100644
typedef struct module_entry {
struct module_entry *next;
char *name, *modname;
-@@ -47,6 +61,7 @@ module_entry *moddb_get(module_db *db, const char *s) FAST_FUNC;
+@@ -47,7 +61,9 @@ module_entry *moddb_get(module_db *db, const char *s) FAST_FUNC;
module_entry *moddb_get_or_create(module_db *db, const char *s) FAST_FUNC;
void moddb_free(module_db *db) FAST_FUNC;
+char *gather_options_str(char *opts, const char *append) FAST_FUNC;
void replace(char *s, char what, char with) FAST_FUNC;
++char *replace_underscores(char *s) FAST_FUNC;
int string_to_llist(char *string, llist_t **llist, const char *delim) FAST_FUNC;
char *filename2modname(const char *filename, char *modname) FAST_FUNC;
+ #if ENABLE_FEATURE_CMDLINE_MODULE_OPTIONS
--
2.13.2
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index f7bf0eecf5e..7cf910f41fe 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.27.0
-pkgrel=0
+pkgrel=1
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -172,7 +172,7 @@ fc17ce9b12726e3449518692bf0d4906c36f091534706b5b91c910866bd8cd50d8f7d4b449d54eee
dc0b660b60ef3028a4cc86f712e7f6d08ad7c00d27056f9978a2a103434f45edc7385d2c48eca5ee83efab8fc81735674bf1c40e78fb07a1b5d07ca9da37811a 0004-ping-make-ping-work-without-root-privileges.patch
63838512679586eb6d83e7b7d3b1e318bb693b91dfb9675a48480e6623e03472b1aa7f86fb7e2ab9e8d6db7a9609b2bcf1c3c1de64fc7d73b65b4794cab87cbf 0005-fbsplash-support-console-switching.patch
1afe261da507ca13869923033a4adbb3c22e512136cc4b771a2d14d0c25d8de6514cec1dd0363b0684410f0e6a274c3250c1ca8a8a839111f3ed16f800b1d403 0006-fbsplash-support-image-and-bar-alignment-and-positio.patch
-1d7df1977eff54da029109bab014505aeb7cd47cd411e455d5309d2fa2970b546e44d97de86649af44a071ab25f0c43846e9ad7256d691cf5a7585d6a059a853 0007-depmod-support-generating-kmod-binary-index-files.patch
+16804d38000bf4395ed2657c19ddf0a1414214db8d2e43541034d5a6db29f74c53c6d8fd28c4c865c7e87fa4a9b914d414e5a00430a261aeaa69ec86bf865780 0007-depmod-support-generating-kmod-binary-index-files.patch
baac796f8aa96fbeab19f96eea7787ace5737b182f49e02f1b1e911d0a927ae14f3c334daad4241858617dc79607541b9ce66b367d0379b2cb32f67a1e9efc5b 0008-diff-add-support-for-no-dereference.patch
d1c375184f806f7550bac5c82ab5471bdb8085d845172c973724b22af05ab3759b3ce982e088b4c45815ade56b9adfb7a677d0c180e077545ac7ec003c8aa7c4 0009-sysklogd-add-Z-option-to-adjust-message-timezones.patch
9b5143d0be615b1604d82007628d59a62721f1e61a63cca7a4ffa5e60fa8da102bfc21fa20cc35c2f5a0a24bc8013598f8eff5888f9d0f3bcfa796343b5f5a91 0010-udhcpc-Don-t-background-if-n-is-given.patch