summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-05-30 18:50:54 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 19:40:47 +0000
commitfc103a1cc69831ea028c1191e7044f6f9371554a (patch)
tree11cbdad1964e378bb7f93c03f072dfc792bc762e /main
parentc9a6b47d0eb6c08ada1168308b10b9215af5a45b (diff)
main/iptables: upgrade to 1.8.3
Diffstat (limited to 'main')
-rw-r--r--main/iptables/APKBUILD13
-rw-r--r--main/iptables/iptables-1.8.2-musl-fixes.patch56
2 files changed, 3 insertions, 66 deletions
diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index 984df60a940..a1201d8c3fb 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iptables
-pkgver=1.8.2
-pkgrel=1
+pkgver=1.8.3
+pkgrel=0
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="https://www.netfilter.org/projects/iptables/index.html"
arch="all"
@@ -13,7 +13,6 @@ subpackages="ip6tables $pkgname-doc $pkgname-dev $pkgname-openrc ip6tables-openr
provides="ebtables" # for backards compat
replaces="ebtables"
source="https://www.netfilter.org/projects/iptables/files/iptables-$pkgver.tar.bz2
- iptables-1.8.2-musl-fixes.patch
iptables.initd
iptables.confd
ip6tables.confd
@@ -23,14 +22,11 @@ builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
sed -i -e '/if_packet/i#define __aligned_u64 __u64 __attribute__((aligned(8)))' \
extensions/libxt_pkttype.c
}
build() {
- cd "$builddir"
-
export CFLAGS="$CFLAGS -D_GNU_SOURCE"
./configure \
--build="$CBUILD" \
@@ -51,8 +47,6 @@ build() {
}
package() {
- cd "$builddir"
-
make -j1 install DESTDIR="$pkgdir"
mkdir -p "$pkgdir"/usr/include/libiptc \
@@ -87,8 +81,7 @@ ip6tables_openrc() {
install -D -m644 "$srcdir"/ip6tables.confd "$subpkgdir"/etc/conf.d/ip6tables
}
-sha512sums="8cf0f515764e1dc6e03284581d682d1949b33e8f25fea29c27ae856f1089fe8ca7b1814524b85f4378fd1fc7c7c7d002f06557b257ae2bbc945f8555bad0dc76 iptables-1.8.2.tar.bz2
-90a4fe20e8adba9a6a0890cccd70896493ddfa36d091cb62e95c0c940a99e32532b877474d53484a74e4aa385ba41a5c51dff485c382e39a0a00618989759196 iptables-1.8.2-musl-fixes.patch
+sha512sums="84b10080646077cbea78b7f3fcc58c6c6e1898213341c69862e1b48179f37a6820c3d84437c896071f966b61aa6d16b132d91948a85fd8c05740f29be3a0986d iptables-1.8.3.tar.bz2
059b3bd8dd7dec60060ec5eb1e639fe8203207629f3a7dd4fdbe5ebca3f7e9b80df5592ebb27542e31830fd15a53cffac5772567053c104dfccf9b78613a31a1 iptables.initd
cb7fecd5cab2c78bd3f215a41f39ec11c37eb360efbe83982378a0e647e0aa9dc0b7ec915a5b5081aa2f7747464787e69404aa15ba15a063c32cb8fb7dd13d1e iptables.confd
0897a7a22f8b700f7f1f5c355ad6cbf39740e44d6c962af99e479978d8a2d556ca7fe4e31f238829046b4a871ce0b5fd52e2544f1361d15dd1ea3e33992646c4 ip6tables.confd"
diff --git a/main/iptables/iptables-1.8.2-musl-fixes.patch b/main/iptables/iptables-1.8.2-musl-fixes.patch
deleted file mode 100644
index efde8746d03..00000000000
--- a/main/iptables/iptables-1.8.2-musl-fixes.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/extensions/libip6t_ipv6header.c
-+++ b/extensions/libip6t_ipv6header.c
-@@ -10,6 +10,9 @@
- #include <netdb.h>
- #include <xtables.h>
- #include <linux/netfilter_ipv6/ip6t_ipv6header.h>
-+#ifndef IPPROTO_HOPOPTS
-+# define IPPROTO_HOPOPTS 0
-+#endif
-
- enum {
- O_HEADER = 0,
---- a/extensions/libxt_TCPOPTSTRIP.c
-+++ b/extensions/libxt_TCPOPTSTRIP.c
-@@ -12,6 +12,21 @@
- #ifndef TCPOPT_MD5SIG
- # define TCPOPT_MD5SIG 19
- #endif
-+#ifndef TCPOPT_MAXSEG
-+# define TCPOPT_MAXSEG 2
-+#endif
-+#ifndef TCPOPT_WINDOW
-+# define TCPOPT_WINDOW 3
-+#endif
-+#ifndef TCPOPT_SACK_PERMITTED
-+# define TCPOPT_SACK_PERMITTED 4
-+#endif
-+#ifndef TCPOPT_SACK
-+# define TCPOPT_SACK 5
-+#endif
-+#ifndef TCPOPT_TIMESTAMP
-+# define TCPOPT_TIMESTAMP 8
-+#endif
-
- enum {
- O_STRIP_OPTION = 0,
---- a/include/linux/netfilter_ipv4/ip_tables.h
-+++ b/include/linux/netfilter_ipv4/ip_tables.h
-@@ -16,6 +16,7 @@
- #define _IPTABLES_H
-
- #include <linux/types.h>
-+#include <sys/types.h>
-
- #include <linux/netfilter_ipv4.h>
-
---- a/extensions/libebt_vlan.c
-+++ b/extensions/libebt_vlan.c
-@@ -12,6 +12,7 @@
- #include <getopt.h>
- #include <ctype.h>
- #include <xtables.h>
-+#include <netinet/if_ether.h>
- #include <linux/netfilter_bridge/ebt_vlan.h>
- #include <linux/if_ether.h>
- #include "iptables/nft.h"