aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-06-12 10:35:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-12 10:35:31 +0000
commit0cef444ac9776f7ff119da6e3c030c1aef3ec246 (patch)
tree6b0b79c89fed106e657f62ebb282d4a94366018a /main
parentb733b0e63d514b339cb49c2ccb505701673e3a09 (diff)
main/sprunge: fix license and modernize
Diffstat (limited to 'main')
-rw-r--r--main/sprunge/APKBUILD42
1 files changed, 15 insertions, 27 deletions
diff --git a/main/sprunge/APKBUILD b/main/sprunge/APKBUILD
index ed055b1b71b..9b00edf6671 100644
--- a/main/sprunge/APKBUILD
+++ b/main/sprunge/APKBUILD
@@ -1,48 +1,36 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sprunge
-pkgver=0.6
-pkgrel=2
+pkgver=0.7
+pkgrel=0
pkgdesc="Helper script to paste things to http://sprunge.us"
url="http://sprunge.us"
arch="noarch"
-license="GPL-2.0"
+license="GPL-2.0-only"
depends="curl"
-makedepends=
-install=""
subpackages="tpaste dpaste dpaste-de:dpaste_de ix"
-source=""
-
-_builddir="$srcdir"
-
-prepare() {
- return 0
-}
-
-build() {
- cd "$_builddir"
-}
+builddir="$srcdir"
package() {
- cd "$_builddir"
+ cd "$builddir"
mkdir -p "$pkgdir"/usr/bin
printf "#!/bin/sh\n\nexec curl -F 'sprunge=<-' http://sprunge.us" > \
- "$pkgdir"/usr/bin/sprunge || return 1
- chmod 755 "$pkgdir"/usr/bin/sprunge || return 1
+ "$pkgdir"/usr/bin/sprunge
+ chmod 755 "$pkgdir"/usr/bin/sprunge
}
tpaste() {
- cd "$_builddir"
+ cd "$builddir"
url="http://tpaste.us"
pkgdesc="Helper script to paste things to $url"
mkdir -p "$subpkgdir"/usr/bin
printf "#!/bin/sh\n\nexec curl -F 'tpaste=<-' http://tpaste.us" > \
- "$subpkgdir"/usr/bin/tpaste || return 1
- chmod 755 "$subpkgdir"/usr/bin/tpaste || return 1
+ "$subpkgdir"/usr/bin/tpaste
+ chmod 755 "$subpkgdir"/usr/bin/tpaste
}
dpaste() {
- cd "$_builddir"
+ cd "$builddir"
url="http://dpaste.com"
pkgdesc="Helper script to paste things to $url"
@@ -53,7 +41,7 @@ dpaste() {
}
dpaste_de() {
- cd "$_builddir"
+ cd "$builddir"
url="https://dpaste.de/"
pkgdesc="Helper script to paste things to $url"
@@ -64,11 +52,11 @@ dpaste_de() {
}
ix() {
- cd "$_builddir"
+ cd "$builddir"
url="http://ix.io"
pkgdesc="Helper script to paste things to $url"
mkdir -p "$subpkgdir"/usr/bin
printf "#!/bin/sh\n\nexec curl -F f:1='<-' ix.io/" > \
- "$subpkgdir"/usr/bin/ix || return 1
- chmod 755 "$subpkgdir"/usr/bin/ix || return 1
+ "$subpkgdir"/usr/bin/ix
+ chmod 755 "$subpkgdir"/usr/bin/ix
}