aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-29 13:53:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-29 13:53:45 +0000
commit186c9c965307d8d7cc9940166f436a0be073472f (patch)
treee88296bd47babf01b6cc13f1fcbd2f9e29c87925 /main
parent0a7ae955e3c00b160263b0c23af289d95d5d7f67 (diff)
main/midori: upgrade to 0.5.10
Diffstat (limited to 'main')
-rw-r--r--main/midori/APKBUILD24
-rw-r--r--main/midori/liststore.patch20
2 files changed, 10 insertions, 34 deletions
diff --git a/main/midori/APKBUILD b/main/midori/APKBUILD
index 592e2db366e..5cb98be1087 100644
--- a/main/midori/APKBUILD
+++ b/main/midori/APKBUILD
@@ -1,22 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=midori
-pkgver=0.5.9
-pkgrel=2
+pkgver=0.5.10
+pkgrel=0
pkgdesc="A lightweight web browser based on Gtk WebKit"
url="http://www.midori-browser.org"
arch="all"
license="LGPL2+"
depends=""
depends_dev="libnotify-dev libunique-dev webkitgtk-dev"
-makedepends=" $depends_dev cmake librsvg-dev paxmark python vala"
+makedepends=" $depends_dev cmake librsvg-dev paxmark python vala gcr-dev"
subpackages="$pkgname-lang"
install=""
source="http://www.midori-browser.org/downloads/midori_${pkgver}_all_.tar.bz2
execinfo-detect.patch
- liststore.patch
"
-_builddir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/
prepare() {
cd "$_builddir"
for i in $source; do
@@ -44,12 +43,9 @@ package() {
paxmark -mp "$pkgdir"/usr/bin/midori || return 1
}
-md5sums="a0af659e0f1d6edb2c97aefdc8c0f097 midori_0.5.9_all_.tar.bz2
-38acb831d862fa8d9aaa9097b4180840 execinfo-detect.patch
-2129acd5db8b098b9c0639ddb5172cb7 liststore.patch"
-sha256sums="b1a5309d926ea4e394f4a39552023b0427cf23053793d325e3daefceed282ec0 midori_0.5.9_all_.tar.bz2
-cc8c5f1402aa7785d67df96f05c72dcbe74c67624834f427e09ceb44ab6d73c7 execinfo-detect.patch
-e1a22ca34bc6306047b96a44f510cc42486e932d5c782862fca0cd341a143735 liststore.patch"
-sha512sums="5f1f42347f85485fd07a12d5dd1c42ab341895be1d5e897ef829bf81357ceae988f6679ef8432688f01168d7ae97ead541d0d732a14b7ac36e033bf3b271b7c2 midori_0.5.9_all_.tar.bz2
-20cd27a801bf1dcf1c9e4e4642a4a342f5a70e0f97843b155588c80f1e4976dd6f8fd95d5e2d6c416de3f7181d0719e3e04d2d09b6a8d105df4510ef0090bc45 execinfo-detect.patch
-9e25d5078de2d92509140dd90edee704b348ca10f6fa2788aed8dda2aa32d6ac614c6d463e5bfb2144ad0473083e2bba50e4ac0ec9eb1e6f0dd23cd7be5955e3 liststore.patch"
+md5sums="2f250a5015923b6eeca606629e7bf042 midori_0.5.10_all_.tar.bz2
+38acb831d862fa8d9aaa9097b4180840 execinfo-detect.patch"
+sha256sums="702344f68d7f034866a46398e35b3c16a5a5f3e431a5d916ea5efc3eaaa3e46f midori_0.5.10_all_.tar.bz2
+cc8c5f1402aa7785d67df96f05c72dcbe74c67624834f427e09ceb44ab6d73c7 execinfo-detect.patch"
+sha512sums="9e615581b2029e2167d13bab3a580cf89b87da4979bb27982f2002b4ddb97e44d27ea910ee60df6479bd0dfa8cbef75217fa1956eb34b13475c99ab25b83f245 midori_0.5.10_all_.tar.bz2
+20cd27a801bf1dcf1c9e4e4642a4a342f5a70e0f97843b155588c80f1e4976dd6f8fd95d5e2d6c416de3f7181d0719e3e04d2d09b6a8d105df4510ef0090bc45 execinfo-detect.patch"
diff --git a/main/midori/liststore.patch b/main/midori/liststore.patch
deleted file mode 100644
index 76f9c0b0575..00000000000
--- a/main/midori/liststore.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./extensions/history-list.vala.orig
-+++ ./extensions/history-list.vala
-@@ -319,7 +319,7 @@
- }
-
- private void create_widgets () {
-- ListStore model;
-+ Gtk.ListStore model;
- TreeIter iter;
- TreeIter? active_iter = null;
-
-@@ -331,7 +331,7 @@
-
- var tab_closing_behavior = this.hl_manager.get_integer ("TabClosingBehavior");
-
-- model = new ListStore (2, typeof (string), typeof (int));
-+ model = new Gtk.ListStore (2, typeof (string), typeof (int));
-
- model.append (out iter);
- model.set (iter, TabClosingBehaviorModel.TEXT, _("Do nothing"),