aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-07 16:04:46 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-19 14:45:40 +0000
commit2241a45c4df5576d6816d9c22c92e05f82e26384 (patch)
treedad7658e427f932e3a0687ea776a0f3c47535566 /main
parent220baeb1d2b89e54c32d01591f99c3ac97ef4475 (diff)
main/libxp: fix url
Diffstat (limited to 'main')
-rw-r--r--main/libxp/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/main/libxp/APKBUILD b/main/libxp/APKBUILD
index f10dea8b2fe..0fef12aa8cc 100644
--- a/main/libxp/APKBUILD
+++ b/main/libxp/APKBUILD
@@ -2,17 +2,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxp
pkgver=1.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="X.Org X11 libXp runtime library"
-url="http://www.x.org"
+options="!check" # No testsuite
+url="https://www.x.org"
arch="all"
license="MIT"
-depends=
makedepends="libx11-dev libxext-dev libxau-dev xorgproto"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.x.org/releases/individual/lib/libXp-$pkgver.tar.bz2
- "
+source="https://www.x.org/releases/individual/lib/libXp-$pkgver.tar.bz2"
builddir="$srcdir"/libXp-$pkgver
build() {
@@ -24,15 +22,11 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-static
make
}
-check() {
- cd "$builddir"
- make check
-}
-
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install