aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-14 07:34:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-14 11:29:57 +0000
commit2aad23004be829b851b1367c3759fa71b5e522e7 (patch)
tree8e915befd7d3774440e94ed6c09acd87590fd608 /main
parente1d77f2907da0d15c9c68b59d1322aab39a2e75c (diff)
main/perl: fix procps circular dependency
drop tests that needs procps so we avoid circluar dependency
Diffstat (limited to 'main')
-rw-r--r--main/perl/APKBUILD7
-rw-r--r--main/perl/skip-test-due-to-busybox-ps.patch22
2 files changed, 26 insertions, 3 deletions
diff --git a/main/perl/APKBUILD b/main/perl/APKBUILD
index 9e270c5a3be..dfd7a2db3ad 100644
--- a/main/perl/APKBUILD
+++ b/main/perl/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=perl
pkgver=5.30.0
-pkgrel=1
+pkgrel=2
pkgdesc="Larry Wall's Practical Extraction and Report Language"
url="https://www.perl.org/"
arch="all"
@@ -11,12 +11,12 @@ license="Artistic GPL-2.0"
options="!fhs"
depends_dev="perl-utils"
makedepends="bzip2-dev zlib-dev"
-checkdepends="procps"
subpackages="$pkgname-doc $pkgname-dev $pkgname-utils::noarch miniperl"
source="https://www.cpan.org/src/5.0/perl-$pkgver.tar.gz
musl-locale.patch
musl-skip-dst-test.patch
79e302e6c3f815bf4cb72a5bacc3012595970db9.patch
+ skip-test-due-to-busybox-ps.patch
"
# secfixes:
@@ -170,4 +170,5 @@ utils() {
sha512sums="b0db58699dfbe1bab10a7b0472cc377ed215668c89d13c7ca693e6b75ab6a6593a9cf137adbd6096063ee8200d83b389e745bb96b7c6bf4cf4588ac587a446ae perl-5.30.0.tar.gz
a78b5fb1a2b6f60b401329cfd2d8349d4fdcc19628cde0e9b840b82e1a02e705f7d7413fe206aa13ed714ab93a65b62ac3d85dfd526ca8048621d5d89b22f0ef musl-locale.patch
3eaec691bc38e208ba4f34130ae45e50b6c339fa50093d0b0f6d7f24cb5b7c2a3734ca714a279c4b51173f82e46a8e7a3e70bfc7d7471a18c55a2102140e4186 musl-skip-dst-test.patch
-caa4a8ff19e56294bc1ff5bebf71802943bf8e82591ec0bfdb895dbbfd45e33d16673b28f938c695e8a2afb494af82e7222621bfb383bcb7d8ac2ba4596252ae 79e302e6c3f815bf4cb72a5bacc3012595970db9.patch"
+caa4a8ff19e56294bc1ff5bebf71802943bf8e82591ec0bfdb895dbbfd45e33d16673b28f938c695e8a2afb494af82e7222621bfb383bcb7d8ac2ba4596252ae 79e302e6c3f815bf4cb72a5bacc3012595970db9.patch
+4e7a3be3291a851b41e484daf5b87d5bc6e372a6f1aea7ad0718fec24fda3719286baa97045255d5d7c0a327a533ff6c32e1bf4d8436550f328fb9b5e602d727 skip-test-due-to-busybox-ps.patch"
diff --git a/main/perl/skip-test-due-to-busybox-ps.patch b/main/perl/skip-test-due-to-busybox-ps.patch
new file mode 100644
index 00000000000..88a19b7139f
--- /dev/null
+++ b/main/perl/skip-test-due-to-busybox-ps.patch
@@ -0,0 +1,22 @@
+diff --git a/t/op/magic.t b/t/op/magic.t
+index 27c1d43..91882f4 100644
+--- a/t/op/magic.t
++++ b/t/op/magic.t
+@@ -408,7 +408,7 @@ EOP
+ # argv[0] assignment and by calling prctl()
+ {
+ SKIP: {
+- skip "We don't have prctl() here, or we're on Android", 2 unless $Config{d_prctl_set_name} && $^O ne 'android';
++ skip "Skip test to avoid external ps(1) dependency", 2;
+
+ # We don't really need these tests. prctl() is tested in the
+ # Kernel, but test it anyway for our sanity. If something doesn't
+@@ -807,7 +807,7 @@ SKIP: {
+ my $me = (split /\0/, $line)[0];
+ is $me, $0, 'altering $0 is effective (testing with /proc/)';
+ close CMDLINE;
+- skip("\$0 check with 'ps' only on Linux (but not Android) and FreeBSD", 1) if $^O eq 'android';
++ skip("\$0 check with 'ps' only on Linux (but not Android) and FreeBSD", 1); # if $^O eq 'android';
+ # perlbug #22811
+ my $mydollarzero = sub {
+ my($arg) = shift;