aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-07-23 14:08:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-23 14:09:19 +0000
commit317172e20de38088b05457b79daf9cef5d729a12 (patch)
treee091233270cb93bf42f4928c8847bc92f29cd5cc /main
parent30b2785ae4dba14bab68e86b671bb17c19605e8a (diff)
main/tmux: use upstream patch
Diffstat (limited to 'main')
-rw-r--r--main/tmux/APKBUILD4
-rw-r--r--main/tmux/tmux-b64_ntop.patch53
2 files changed, 49 insertions, 8 deletions
diff --git a/main/tmux/APKBUILD b/main/tmux/APKBUILD
index 51cefeab186..b55196c50ce 100644
--- a/main/tmux/APKBUILD
+++ b/main/tmux/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tmux
pkgver=1.5
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to control multiple terminals from a single terminal"
url="http://tmux.sourceforge.net/"
arch="all"
@@ -39,4 +39,4 @@ package() {
}
md5sums="3d4b683572af34e83bc8b183a8285263 tmux-1.5.tar.gz
-0fe2460847932e5427ee94dbc8a29c41 tmux-b64_ntop.patch"
+c3860d7a0c1cc201e307f20fee16facc tmux-b64_ntop.patch"
diff --git a/main/tmux/tmux-b64_ntop.patch b/main/tmux/tmux-b64_ntop.patch
index a2d28c70a12..e514fff41ee 100644
--- a/main/tmux/tmux-b64_ntop.patch
+++ b/main/tmux/tmux-b64_ntop.patch
@@ -1,8 +1,25 @@
Index: configure.ac
===================================================================
---- configure.ac (revision 2561)
+--- configure.ac (revision 2564)
+++ configure.ac (working copy)
-@@ -122,8 +122,12 @@
+@@ -105,9 +105,14 @@
+ AC_SEARCH_LIBS(clock_gettime, rt)
+
+ # Look for libevent.
+-AC_SEARCH_LIBS(event_init, [event event-1.4 event2], found_libevent=yes, found_libevent=no)
++AC_SEARCH_LIBS(
++ event_init,
++ [event event-1.4 event2],
++ found_libevent=yes,
++ found_libevent=no
++)
+ if test "x$found_libevent" = xno; then
+- AC_MSG_ERROR("libevent not found")
++ AC_MSG_ERROR("libevent not found")
+ fi
+
+ # Look for curses.
+@@ -122,8 +127,14 @@
fi
# Look for networking libraries.
@@ -10,16 +27,34 @@ Index: configure.ac
-AC_SEARCH_LIBS(__b64_ntop, resolv)
+AC_SEARCH_LIBS(b64_ntop, resolv, found_b64_ntop=yes, found_b64_ntop=no)
+AC_SEARCH_LIBS(__b64_ntop, resolv, found___b64_ntop=yes, found___b64_ntop=no)
-+if test "x$found_b64_ntop" = xyes -o "x$found___b64_ntop" = yes; then
++if test "x$found_b64_ntop" = xyes -o "x$found___b64_ntop" = xyes; then
+ AC_DEFINE(HAVE_B64_NTOP)
+fi
-+AM_CONDITIONAL(NO_B64_NTOP, [test "x$found_b64_ntop" = xno -a "x$found___b64_ntop" = xno])
++AM_CONDITIONAL(
++ NO_B64_NTOP,
++ [test "x$found_b64_ntop" = xno -a "x$found___b64_ntop" = xno])
AC_SEARCH_LIBS(inet_ntoa, nsl)
AC_SEARCH_LIBS(socket, socket)
AC_CHECK_LIB(xnet, socket)
+Index: compat.h
+===================================================================
+--- compat.h (revision 2564)
++++ compat.h (working copy)
+@@ -196,6 +196,11 @@
+ int daemon(int, int);
+ #endif
+
++#ifndef HAVE_B64_NTOP
++/* b64_ntop.c */
++int b64_ntop(const char *, size_t, char *, size_t);
++#endif
++
+ #ifndef HAVE_FORKPTY
+ /* forkpty.c */
+ #include <sys/ioctl.h>
Index: Makefile.am
===================================================================
---- Makefile.am (revision 2561)
+--- Makefile.am (revision 2564)
+++ Makefile.am (working copy)
@@ -226,6 +226,9 @@
if NO_STRTONUM
@@ -34,7 +69,7 @@ Index: Makefile.am
Index: compat/b64_ntop.c
===================================================================
--- compat/b64_ntop.c (revision 0)
-+++ compat/b64_ntop.c (revision 0)
++++ compat/b64_ntop.c (revision 2566)
@@ -0,0 +1,182 @@
+/*
+ * Copyright (c) 1996, 1998 by Internet Software Consortium.
@@ -218,3 +253,9 @@ Index: compat/b64_ntop.c
+ target[datalength] = '\0'; /* Returned value doesn't count \0. */
+ return (datalength);
+}
+
+Property changes on: compat/b64_ntop.c
+___________________________________________________________________
+Added: svn:keywords
+ + Id
+